summaryrefslogtreecommitdiff
path: root/user/perl-test-command-simple
diff options
context:
space:
mode:
authorKiyoshi Aman <adelie@aerdan.vulpine.house>2020-02-15 00:48:27 -0500
committerKiyoshi Aman <adelie@aerdan.vulpine.house>2020-02-15 00:48:27 -0500
commit715748b15cd863832acd8705aa8d70383ca6c6bc (patch)
treecb8ef1b5f581f71920bc1cfb9b1b1b6be792c5af /user/perl-test-command-simple
parent28fa76709bca5b89323918beba509d2dbd195758 (diff)
downloadpackages-715748b15cd863832acd8705aa8d70383ca6c6bc.tar.gz
packages-715748b15cd863832acd8705aa8d70383ca6c6bc.tar.bz2
packages-715748b15cd863832acd8705aa8d70383ca6c6bc.tar.xz
packages-715748b15cd863832acd8705aa8d70383ca6c6bc.zip
user/perl-test-command-simple: new package
Diffstat (limited to 'user/perl-test-command-simple')
-rw-r--r--user/perl-test-command-simple/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/user/perl-test-command-simple/APKBUILD b/user/perl-test-command-simple/APKBUILD
new file mode 100644
index 000000000..27ebb0f99
--- /dev/null
+++ b/user/perl-test-command-simple/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
+pkgname=perl-test-command-simple
+pkgver=0.05
+pkgrel=0
+pkgdesc="Simple interface for testing external commands in Perl"
+url="https://metacpan.org/pod/Test::Command::Simple"
+arch="noarch"
+license="Artistic-2.0 OR GPL-1.0+"
+depends="perl"
+makedepends="perl-dev"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/D/DM/DMCBRIDE/Test-Command-Simple-$pkgver.tar.gz"
+builddir="$srcdir/Test-Command-Simple-$pkgver"
+
+build() {
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="65c921785d775a782dae9d3a3b81350374cb97bb09dd604aab71aeaed4e6818e32d8fd60c97b88d3d11ff9be8e28f0c082246e4c8981f1e36b6268464fc71c9b Test-Command-Simple-0.05.tar.gz"