summaryrefslogtreecommitdiff
path: root/user/perl-test-perltidy/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2019-10-17 22:52:43 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2019-10-17 22:52:43 +0000
commit3401220890b38e9d9bd3c50bed2a88f98bc8e645 (patch)
tree3533c905623209cb1525c2c1a935d710b18d7efc /user/perl-test-perltidy/APKBUILD
parentc665adb6aa1d2253d650989bd6f72ceca79747d1 (diff)
parentb163eb1b88e25226d5a45816367522bffac0a978 (diff)
downloadpackages-3401220890b38e9d9bd3c50bed2a88f98bc8e645.tar.gz
packages-3401220890b38e9d9bd3c50bed2a88f98bc8e645.tar.bz2
packages-3401220890b38e9d9bd3c50bed2a88f98bc8e645.tar.xz
packages-3401220890b38e9d9bd3c50bed2a88f98bc8e645.zip
Merge branch 'perl.authors' into 'master'
Modernise Perl packages See merge request adelie/packages!367
Diffstat (limited to 'user/perl-test-perltidy/APKBUILD')
-rw-r--r--user/perl-test-perltidy/APKBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/user/perl-test-perltidy/APKBUILD b/user/perl-test-perltidy/APKBUILD
index 428c833cf..d631c4fa1 100644
--- a/user/perl-test-perltidy/APKBUILD
+++ b/user/perl-test-perltidy/APKBUILD
@@ -1,6 +1,10 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-test-perltidy
+_pkgreal=Test-PerlTidy
+_author=SHLOMIF
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
pkgver=20190402
pkgrel=0
pkgdesc="Check all your Perl files for tidiness"
@@ -9,24 +13,21 @@ arch="noarch"
license="Artistic-1.0-Perl"
depends="perl-file-finder perl-file-slurp perl-perl-tidy perl-text-diff"
checkdepends="perl-path-tiny"
-makedepends="perl-dev"
+makedepends=""
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/S/SH/SHLOMIF/Test-PerlTidy-$pkgver.tar.gz"
-builddir="$srcdir/Test-PerlTidy-$pkgver"
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}