summaryrefslogtreecommitdiff
path: root/user/plasma-workspace
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-12-29 02:44:11 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2017-12-29 02:44:11 -0600
commitcf5e3c7c71d481c4c5005c8353587dccea4238fa (patch)
tree4a9437eb05b6d5f97506a2cdd8541f6431a45206 /user/plasma-workspace
parent54252e3f3ad2451193df2e01af5d2acfad1db83e (diff)
downloadpackages-cf5e3c7c71d481c4c5005c8353587dccea4238fa.tar.gz
packages-cf5e3c7c71d481c4c5005c8353587dccea4238fa.tar.bz2
packages-cf5e3c7c71d481c4c5005c8353587dccea4238fa.tar.xz
packages-cf5e3c7c71d481c4c5005c8353587dccea4238fa.zip
user/plasma-workspace: fix crash on wallpaper change
Diffstat (limited to 'user/plasma-workspace')
-rw-r--r--user/plasma-workspace/APKBUILD9
-rw-r--r--user/plasma-workspace/fix-crash-on-wallpaper-change.patch58
2 files changed, 64 insertions, 3 deletions
diff --git a/user/plasma-workspace/APKBUILD b/user/plasma-workspace/APKBUILD
index c018eef8c..c6b4dc276 100644
--- a/user/plasma-workspace/APKBUILD
+++ b/user/plasma-workspace/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=plasma-workspace
pkgver=5.8.7
-pkgrel=7
+pkgrel=8
pkgdesc="KDE Plasma 5 workspace"
url="https://www.kde.org/plasma-desktop"
arch="all"
@@ -30,7 +30,9 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="https://download.kde.org/Attic/plasma/$pkgver/plasma-workspace-$pkgver.tar.xz
plasma-workspace-5.8-cmake-update.patch
plasma-workspace-5.8.7-disable-broken-test.patch
- plasma-workspace-5.8-honour-uint.patch"
+ plasma-workspace-5.8-honour-uint.patch
+ fix-crash-on-wallpaper-change.patch
+ "
builddir="$srcdir/plasma-workspace-$pkgver"
build() {
@@ -62,4 +64,5 @@ package() {
sha512sums="ba35a050384e0bf410097027bfb70ca7594cd5352fd6470228d537f4e876ec72ec26bac3be9a6750f306b1d2937ff53c267c2246f191c93a13972a0cf33b4faf plasma-workspace-5.8.7.tar.xz
3d7cfb1c7c54bcbca47c5c01497c776d54d1e2327bc0a3777cfaf001f44ec7c1863f15ab0586c00db6d7194f759b91d0a86e47ae99e7fa23782dd7deda264e47 plasma-workspace-5.8-cmake-update.patch
2151dab30716e0b2b6a9146fd6262f4f134884961bebe9cf9baee269f35b1b3955ed07dcee2602b5adc2fc93aa15d37cb72d6983f026a2b504feb451d944d965 plasma-workspace-5.8.7-disable-broken-test.patch
-48b4c448a4e964e61f25fa751fbc67f6cfce0e792139a124a70fa5c07f8b1b1a1c51fd5652679a3c46ac997c2dda3df476e8c8ebfdc6a08ece4f2e79282d81a3 plasma-workspace-5.8-honour-uint.patch"
+48b4c448a4e964e61f25fa751fbc67f6cfce0e792139a124a70fa5c07f8b1b1a1c51fd5652679a3c46ac997c2dda3df476e8c8ebfdc6a08ece4f2e79282d81a3 plasma-workspace-5.8-honour-uint.patch
+52ac2f37a7e1fde97385a372a4c198b573fb51fe1334bddf340c034ba0fbd2a97174d9bab9f9c8446048deb3a2c9ea3c571b0adcdb1f710b513b311c824ab88a fix-crash-on-wallpaper-change.patch"
diff --git a/user/plasma-workspace/fix-crash-on-wallpaper-change.patch b/user/plasma-workspace/fix-crash-on-wallpaper-change.patch
new file mode 100644
index 000000000..078a48e3a
--- /dev/null
+++ b/user/plasma-workspace/fix-crash-on-wallpaper-change.patch
@@ -0,0 +1,58 @@
+From a44d84ef47492ca60ee608996b5ab1f2849ef16e Mon Sep 17 00:00:00 2001
+From: David Edmundson <kde@davidedmundson.co.uk>
+Date: Mon, 14 Aug 2017 10:04:19 +0100
+Subject: Don't change fillMode of image just before deleting it
+
+It is still set for when a source is applied for the next
+transistion.
+
+Summary:
+This saves evaluating a new paintedSize and doing a bunch of evaluations
+which are not used.
+
+More importantly it works round a Qt animation crash.
+
+fadeAnim.running is bound to otherImage.status !== loading
+
+with the intention of delaying animations until the images are really
+loaded.
+
+By setting the fill mode and then the source, we go to loading and back,
+effectively restarting the animation from within the animation.
+This leads to a crash.
+
+CCBUG: 381105
+
+Test Plan:
+End user result is the same.
+
+Reviewers: #plasma, broulik, mart
+
+Reviewed By: #plasma, broulik, mart
+
+Subscribers: plasma-devel
+
+Tags: #plasma
+
+Differential Revision: https://phabricator.kde.org/D7248
+---
+ wallpapers/image/imagepackage/contents/ui/main.qml | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/wallpapers/image/imagepackage/contents/ui/main.qml b/wallpapers/image/imagepackage/contents/ui/main.qml
+index fc22176..0539f37 100644
+--- a/wallpapers/image/imagepackage/contents/ui/main.qml
++++ b/wallpapers/image/imagepackage/contents/ui/main.qml
+@@ -193,8 +193,8 @@ Item {
+ }
+ ScriptAction {
+ script: {
+- otherImage.fillMode = fillMode;
+ otherImage.source = "";
++ otherImage.fillMode = fillMode;
+ }
+ }
+ }
+--
+cgit v0.11.2
+