summaryrefslogtreecommitdiff
path: root/user/pluma/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2019-03-25 04:35:41 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2019-03-25 04:35:41 +0000
commit2aac7c91d6a22da9af6ac791200ecae2fd64fd4e (patch)
tree767814e8ae339c1379444d061eb47c81a590e112 /user/pluma/APKBUILD
parent13fa4c900a5d7825c4802b12cecdf6e22e9dfac8 (diff)
parentdc9e13229a7c2d216ec98a16075601b9540f7e53 (diff)
downloadpackages-2aac7c91d6a22da9af6ac791200ecae2fd64fd4e.tar.gz
packages-2aac7c91d6a22da9af6ac791200ecae2fd64fd4e.tar.bz2
packages-2aac7c91d6a22da9af6ac791200ecae2fd64fd4e.tar.xz
packages-2aac7c91d6a22da9af6ac791200ecae2fd64fd4e.zip
Merge branch 'desktops.mate' into 'master'
Package the MATE desktop environment See merge request !207
Diffstat (limited to 'user/pluma/APKBUILD')
-rw-r--r--user/pluma/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/user/pluma/APKBUILD b/user/pluma/APKBUILD
new file mode 100644
index 000000000..4e6d80e39
--- /dev/null
+++ b/user/pluma/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=pluma
+pkgver=1.22.0
+pkgrel=0
+pkgdesc="Text editor for the MATE desktop environment"
+url="https://mate-desktop.org"
+arch="all"
+options="!check" # tests fail due to schema being requested but not available
+license="GPL-2.0+ AND GPL-2.0-only AND LGPL-2.0+"
+depends=""
+makedepends="gtk+3.0-dev gtksourceview-3.0-dev enchant-dev intltool
+ itstool iso-codes-dev libpeas-dev libsm-dev libxml2-dev libxml2-utils"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="https://pub.mate-desktop.org/releases/${pkgver%.*}/pluma-$pkgver.tar.xz"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="7c74c2ce0a89ec3813c936449d3114957e7b319433875ef567ecc508a28a1d3ddc3d0da418b2eb1278b6dc9dbaa3c75a279524f5a061b5aecb52955edcf28f51 pluma-1.22.0.tar.xz"