summaryrefslogtreecommitdiff
path: root/user/py3-attrs
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2018-10-22 20:34:54 -0400
committerMax Rees <maxcrees@me.com>2018-10-22 20:34:54 -0400
commite9c9bbec9cd0f143eeab03b192f3acca6079c18d (patch)
tree8c1cf1fbb9f76abd794c4f184eae31967d577684 /user/py3-attrs
parenteb565903fcdedcb73ff963a3e9217341921ad8b5 (diff)
downloadpackages-e9c9bbec9cd0f143eeab03b192f3acca6079c18d.tar.gz
packages-e9c9bbec9cd0f143eeab03b192f3acca6079c18d.tar.bz2
packages-e9c9bbec9cd0f143eeab03b192f3acca6079c18d.tar.xz
packages-e9c9bbec9cd0f143eeab03b192f3acca6079c18d.zip
user/py3-attrs: drop py3-tox dep, certify
Diffstat (limited to 'user/py3-attrs')
-rw-r--r--user/py3-attrs/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/user/py3-attrs/APKBUILD b/user/py3-attrs/APKBUILD
index fad246453..ec2bb62c3 100644
--- a/user/py3-attrs/APKBUILD
+++ b/user/py3-attrs/APKBUILD
@@ -7,11 +7,12 @@ pkgdesc="Python classes without boilerplate"
url="https://www.attrs.org"
arch="noarch"
options="!check" # Circular dependency with py3-pytest. Passes on x86_64
+# Certified net clean
license="MIT"
depends="python3"
makedepends="python3-dev"
-#checkdepends="py3-tox"
-source="py3-attrs-$pkgver.tar.gz::https://github.com/python-attrs/attrs/archive/$pkgver.tar.gz"
+#checkdepends="py3-pytest py3-hypothesis py3-six"
+source="$pkgname-$pkgver.tar.gz::https://github.com/python-attrs/attrs/archive/$pkgver.tar.gz"
builddir="$srcdir/attrs-$pkgver"
build() {
@@ -21,7 +22,7 @@ build() {
check() {
cd "$builddir"
- tox -e py36
+ pytest
}
package() {