summaryrefslogtreecommitdiff
path: root/user/py3-chardet
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-26 21:49:53 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-26 21:49:53 -0600
commit52230acde8f9d67a9a70a55553b99f89072c6c73 (patch)
treea3d0fce94cc7813c6331969ddd1e87c9205f858c /user/py3-chardet
parentb65d572bc23d04bd90823e4d3a6a5770ea85a4f7 (diff)
downloadpackages-52230acde8f9d67a9a70a55553b99f89072c6c73.tar.gz
packages-52230acde8f9d67a9a70a55553b99f89072c6c73.tar.bz2
packages-52230acde8f9d67a9a70a55553b99f89072c6c73.tar.xz
packages-52230acde8f9d67a9a70a55553b99f89072c6c73.zip
user/py3-chardet: enable testing since we have hypothesis now
Diffstat (limited to 'user/py3-chardet')
-rw-r--r--user/py3-chardet/APKBUILD16
-rw-r--r--user/py3-chardet/pytest.patch24
2 files changed, 34 insertions, 6 deletions
diff --git a/user/py3-chardet/APKBUILD b/user/py3-chardet/APKBUILD
index f33618402..e9d6fce3f 100644
--- a/user/py3-chardet/APKBUILD
+++ b/user/py3-chardet/APKBUILD
@@ -10,23 +10,27 @@ pkgrel=0
pkgdesc="The Universal Character Encoding Detector"
url="https://github.com/chardet/chardet/"
arch="noarch"
-options="!check" # tests use hypothesis; deep rabbit hole
license="LGPL-2.1-only"
depends="python3"
+checkdepends="py3-hypothesis py3-pytest"
makedepends="python3-dev"
subpackages=""
-source="https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz"
+source="https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz
+ pytest.patch
+ "
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
python3 setup.py build
}
+check() {
+ python3 setup.py test
+}
+
package() {
- mkdir -p "$pkgdir"
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
}
-sha512sums="61a03b23447a2bfe52ceed4dd1b9afdb5784da1933a623776883ee9f297e341f633e27f0ce0230bd5fdc5fdb5382105ab42736a74a417ddeb9f83af57455dba5 chardet-3.0.4.tar.gz"
+sha512sums="61a03b23447a2bfe52ceed4dd1b9afdb5784da1933a623776883ee9f297e341f633e27f0ce0230bd5fdc5fdb5382105ab42736a74a417ddeb9f83af57455dba5 chardet-3.0.4.tar.gz
+57bfeb5752123fbf9f9f61386039b7ceb9255290225f73453d2d52f2366e1949ed92692912571c8b451b521aedfa8b605879b2742aec7f1fdce4db10705cbe53 pytest.patch"
diff --git a/user/py3-chardet/pytest.patch b/user/py3-chardet/pytest.patch
new file mode 100644
index 000000000..039816b78
--- /dev/null
+++ b/user/py3-chardet/pytest.patch
@@ -0,0 +1,24 @@
+From 440828f8faafdb58700c64a9ea8f6a30b154c08b Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
+Date: Mon, 11 Nov 2019 21:02:51 +0100
+Subject: [PATCH] Support pytest 4, don't apply marks directly to parameters
+ (#174)
+
+Fixes https://github.com/chardet/chardet/issues/173
+---
+ test.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/test.py b/test.py
+index 9833307..ad2b753 100644
+--- a/test.py
++++ b/test.py
+@@ -59,7 +59,7 @@ def gen_test_params():
+ full_path = join(path, file_name)
+ test_case = full_path, encoding
+ if full_path in EXPECTED_FAILURES:
+- test_case = pytest.mark.xfail(test_case)
++ test_case = pytest.param(*test_case, marks=pytest.mark.xfail)
+ yield test_case
+
+