summaryrefslogtreecommitdiff
path: root/user/py3-future/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2019-03-18 18:54:42 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2019-03-18 18:54:42 +0000
commit32c38901a3117b823697bdcd7adafec4607912d6 (patch)
tree23f9d3ffcaf5505c086cd4f0ca026f58b08fec38 /user/py3-future/APKBUILD
parent40254b068b9389c30608184e33ffce42ee3fc74c (diff)
parent86bc7fce4c621370283feab618a2911c365d5deb (diff)
downloadpackages-32c38901a3117b823697bdcd7adafec4607912d6.tar.gz
packages-32c38901a3117b823697bdcd7adafec4607912d6.tar.bz2
packages-32c38901a3117b823697bdcd7adafec4607912d6.tar.xz
packages-32c38901a3117b823697bdcd7adafec4607912d6.zip
Merge branch 'zlg.2019-03' into 'master'
zlg's package bumps for March 2019 This is a routine package upgrade. There is one thing to note, however: * `py3-pyyaml` has a minor issue building due to a missing `ext/_yaml.c` file. It appears that a tool is used to generate the `.c` file it needs to compile the module. It falls back to pure-Python mode and passes all tests, however. I hand-tested `py3-pyyaml` by using vgstash to export a game collection to yaml (everything worked fine) and received a test cert from `certbot` to confirm the bumps didn't break anything affected on my system, since they're the two largest consumers of what was bumped. This should be the last version bump from me until post-1.0-BETA3, barring security bumps. See merge request !202
Diffstat (limited to 'user/py3-future/APKBUILD')
-rw-r--r--user/py3-future/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/user/py3-future/APKBUILD b/user/py3-future/APKBUILD
index d98fc65c2..7f433a4fc 100644
--- a/user/py3-future/APKBUILD
+++ b/user/py3-future/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: zlg <zlg+adelie@zlg.space>
pkgname=py3-future
-_pkgname=python-future
-pkgver=0.17.0
+_pkgname=${pkgname##py3-}
+pkgver=0.17.1
pkgrel=0
pkgdesc="Easy, clean, reliable Python 2/3 compatibility"
url="http://python-future.org/"
@@ -12,7 +12,7 @@ license="MIT"
depends="python3"
makedepends="python3-dev"
subpackages=""
-source="$pkgname-$pkgver.tar.gz::https://github.com/PythonCharmers/$_pkgname/archive/v$pkgver.tar.gz"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
@@ -26,4 +26,4 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="0b914ba062dd2b3c6837d8d8d274d27faadc587b264e887266527940fa7b4b98ce1b0076f1e589f943406d24b9e17f3ae8c2060c4ffa2207f620040988c176a3 py3-future-0.17.0.tar.gz"
+sha512sums="50094c44db81afbfd37ee25e1710ed11ecb2c2d64ad076fb62a2688dd36a9696ab26b0d7989bf1ecb10da251961a0ee6bb37c4dbd115f70384cd8c9a675d0b2d future-0.17.1.tar.gz"