summaryrefslogtreecommitdiff
path: root/user/py3-html5lib/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2019-04-07 14:45:15 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2019-04-07 14:45:15 +0000
commitc5f8a52a58247448855b0b81bae867e5ab31cfef (patch)
tree303ca612dd27096250f7e9d3e6ad739f2dd2ef11 /user/py3-html5lib/APKBUILD
parent94628432b84d6c739deab02e7ed9a532f517a686 (diff)
parent64d7aa8301c599bf348897882e50f2a94d7b60df (diff)
downloadpackages-c5f8a52a58247448855b0b81bae867e5ab31cfef.tar.gz
packages-c5f8a52a58247448855b0b81bae867e5ab31cfef.tar.bz2
packages-c5f8a52a58247448855b0b81bae867e5ab31cfef.tar.xz
packages-c5f8a52a58247448855b0b81bae867e5ab31cfef.zip
Merge branch 'py3-sphinx' into 'master'
Add py3-sphinx and its dependencies. This will be needed in the future to build qemu-doc for qemu 4.0. See merge request !214
Diffstat (limited to 'user/py3-html5lib/APKBUILD')
-rw-r--r--user/py3-html5lib/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/user/py3-html5lib/APKBUILD b/user/py3-html5lib/APKBUILD
new file mode 100644
index 000000000..f65096fad
--- /dev/null
+++ b/user/py3-html5lib/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Brandon Bergren <git@bdragon.rtk0.net>
+# Maintainer: Brandon Bergren <git@bdragon.rtk0.net>
+pkgname=py3-html5lib
+_pkgname=html5lib
+pkgver=1.0.1
+pkgrel=0
+pkgdesc="HTML parser based on the WHATWG HTML specification"
+url="https://pypi.python.org/pypi/html5lib"
+arch="noarch"
+license="MIT"
+depends="python3 py3-six py3-webencodings"
+makedepends="python3-dev"
+checkdepends="py3-pytest py3-mock py3-pytest-expect"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ pytest
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+
+}
+
+sha512sums="35939b4450893864da04e735ee5e0addacf1dd34bae6a6909c76572abf6bfded446a78a713dfde91c1485ba45867d7abeb6a45cf0545c16ea968707be7de5dd2 py3-html5lib-1.0.1.tar.gz"