summaryrefslogtreecommitdiff
path: root/user/py3-hypothesis
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2019-04-07 14:45:15 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2019-04-07 14:45:15 +0000
commitc5f8a52a58247448855b0b81bae867e5ab31cfef (patch)
tree303ca612dd27096250f7e9d3e6ad739f2dd2ef11 /user/py3-hypothesis
parent94628432b84d6c739deab02e7ed9a532f517a686 (diff)
parent64d7aa8301c599bf348897882e50f2a94d7b60df (diff)
downloadpackages-c5f8a52a58247448855b0b81bae867e5ab31cfef.tar.gz
packages-c5f8a52a58247448855b0b81bae867e5ab31cfef.tar.bz2
packages-c5f8a52a58247448855b0b81bae867e5ab31cfef.tar.xz
packages-c5f8a52a58247448855b0b81bae867e5ab31cfef.zip
Merge branch 'py3-sphinx' into 'master'
Add py3-sphinx and its dependencies. This will be needed in the future to build qemu-doc for qemu 4.0. See merge request !214
Diffstat (limited to 'user/py3-hypothesis')
-rw-r--r--user/py3-hypothesis/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/user/py3-hypothesis/APKBUILD b/user/py3-hypothesis/APKBUILD
new file mode 100644
index 000000000..808a84296
--- /dev/null
+++ b/user/py3-hypothesis/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Brandon Bergren <git@bdragon.rtk0.net>
+# Maintainer: Brandon Bergren <git@bdragon.rtk0.net>
+pkgname=py3-hypothesis
+_pkgname=hypothesis
+pkgver=4.14.3
+pkgrel=0
+pkgdesc="A library for property based testing"
+url="https://pypi.python.org/pypi/hypothesis"
+arch="noarch"
+options="!check" # Tests are missing from release packages due to possible packaging bug?
+license="MPL-2.0"
+depends="python3"
+makedepends="python3-dev"
+checkdepends="py3-pytest py3-attrs"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py test
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+
+}
+
+sha512sums="6cf0713a416c51286e4c707c6b32705b2dd53ff1a5c88ceab0cdd970e8932078c9e13436ac4aa66f94a5badf0a2f93a20e8221f77cf4fb0c8b42a707b52fb0f2 py3-hypothesis-4.14.3.tar.gz"