summaryrefslogtreecommitdiff
path: root/user/py3-packaging/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2019-08-08 03:31:00 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2019-08-08 03:31:00 +0000
commita01cc01896f6fb3b472622711d632100b3c86cdb (patch)
tree21fb15bbd40fabb290446ee3aa09e491306f2a87 /user/py3-packaging/APKBUILD
parent5c572c8c2013c5833d041ea4411a189d85f312fa (diff)
parent3f98aef31c277c4f673d3ad9db6b11b6e973ea5e (diff)
downloadpackages-a01cc01896f6fb3b472622711d632100b3c86cdb.tar.gz
packages-a01cc01896f6fb3b472622711d632100b3c86cdb.tar.bz2
packages-a01cc01896f6fb3b472622711d632100b3c86cdb.tar.xz
packages-a01cc01896f6fb3b472622711d632100b3c86cdb.zip
Merge branch 'sr.2019.08.06' into 'master'
Misc package bumps for Maintainer: Max Rees, 2019.08.06 See merge request adelie/packages!313
Diffstat (limited to 'user/py3-packaging/APKBUILD')
-rw-r--r--user/py3-packaging/APKBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/user/py3-packaging/APKBUILD b/user/py3-packaging/APKBUILD
index 87527b822..1bd5298dd 100644
--- a/user/py3-packaging/APKBUILD
+++ b/user/py3-packaging/APKBUILD
@@ -4,32 +4,33 @@ pkgname=py3-packaging
_pkgname=packaging
_p="${_pkgname#?}"
_p="${_pkgname%"$_p"}"
-pkgver=19.0
+pkgver=19.1
pkgrel=0
pkgdesc="Core utilities for Python packages"
url="https://pypi.python.org/pypi/packaging"
arch="noarch"
+options="!check" # Cyclic dependency with py3-pytest.
+# Certified net clean
license="Apache-2.0 AND BSD-2-Clause"
-depends="python3"
+depends="python3 py3-attrs py3-pyparsing py3-six"
makedepends="python3-dev"
-checkdepends="py3-pytest py3-pretend py3-pyparsing"
-source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz"
+#checkdepends="py3-pytest py3-pretend"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz
+ test-glibc.patch"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir/tests"
- python3 -m pytest
+ PYTHONPATH="$builddir" pytest
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="aa55b6fbca764e7de2992e294b7be9dc90b25f88b64ba0cd2d1d93042402d4360b4c2cdc134a94b083da0c0bc83de8fa7185c0856bcc96fa25828c10a793fba7 py3-packaging-19.0.tar.gz"
+sha512sums="1dec7f49c325801eb85b11432f8a316d228bb1881a04ac546f5556d60f5fa33f8085d0e91bbd5abfeb30bfcb05ec0532ed75a977dc996e256b4dc8c27c10e79b py3-packaging-19.1.tar.gz
+d67e8f3eae1b7571edf705ba532e1c9a6dc4c241cb01dfeda8addb587c2039114b0e21e73140369e4a30d0256a2073ac877737458cb95006029e7ce44d0bae93 test-glibc.patch"