summaryrefslogtreecommitdiff
path: root/user/py3-paho-mqtt/setup.patch
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2019-09-28 15:04:14 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2019-09-28 15:04:14 +0000
commit5cd64ffbbf9c1744efcb0319d30735ce2cf5b471 (patch)
tree8150bc345cbcb976330aaa52882412e957aa4a62 /user/py3-paho-mqtt/setup.patch
parentf9ba226858a27bb322bad90ad988971f9afa8314 (diff)
parentdee3259450baedd016093d7ec23f1664a942822a (diff)
downloadpackages-5cd64ffbbf9c1744efcb0319d30735ce2cf5b471.tar.gz
packages-5cd64ffbbf9c1744efcb0319d30735ce2cf5b471.tar.bz2
packages-5cd64ffbbf9c1744efcb0319d30735ce2cf5b471.tar.xz
packages-5cd64ffbbf9c1744efcb0319d30735ce2cf5b471.zip
Merge branch 'mqtt' into 'master'
Add mosquitto and py3-paho-mqtt See merge request adelie/packages!328
Diffstat (limited to 'user/py3-paho-mqtt/setup.patch')
-rw-r--r--user/py3-paho-mqtt/setup.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/user/py3-paho-mqtt/setup.patch b/user/py3-paho-mqtt/setup.patch
new file mode 100644
index 000000000..70ccc869f
--- /dev/null
+++ b/user/py3-paho-mqtt/setup.patch
@@ -0,0 +1,24 @@
+--- paho.mqtt.python-1.4.0/setup.py 2018-09-02 11:20:42.000000000 +0000
++++ paho.mqtt.python-1.4.0/setup.py 2019-08-28 02:51:55.690633661 +0000
+@@ -11,9 +11,8 @@ with open('README.rst', 'rb') as readme_
+ readme = readme_file.read().decode('utf-8')
+
+ requirements = []
+-test_requirements = ['pytest', 'pylama']
+-needs_pytest = {'pytest', 'test', 'ptr'}.intersection(sys.argv)
+-setup_requirements = ['pytest-runner'] if needs_pytest else []
++test_requirements = ['pytest']
++setup_requirements = []
+
+ if sys.version_info < (3, 0):
+ test_requirements += ['mock']
+--- paho.mqtt.python-1.4.0/setup.cfg 2018-09-02 11:20:42.000000000 +0000
++++ paho.mqtt.python-1.4.0/setup.cfg 2019-08-28 02:50:19.540632984 +0000
+@@ -1,7 +1,6 @@
+ [aliases]
+ test=pytest
+ [tool:pytest]
+-addopts=-r xs --pylama
+ strict=True
+ testpaths=tests src
+ [pylama]