summaryrefslogtreecommitdiff
path: root/user/py3-paho-mqtt
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-12 07:07:54 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-12 07:07:54 +0000
commit3628919d4a259adb4894b9936f765bd3b1ba62ab (patch)
tree845692716cb0a73ea75b1ae34ad09af5125b862c /user/py3-paho-mqtt
parentbcb53fe3cd0656e8c52f6951044d61613f0f216e (diff)
downloadpackages-3628919d4a259adb4894b9936f765bd3b1ba62ab.tar.gz
packages-3628919d4a259adb4894b9936f765bd3b1ba62ab.tar.bz2
packages-3628919d4a259adb4894b9936f765bd3b1ba62ab.tar.xz
packages-3628919d4a259adb4894b9936f765bd3b1ba62ab.zip
user/py3-paho-mqtt: Bump to 1.5.0
Diffstat (limited to 'user/py3-paho-mqtt')
-rw-r--r--user/py3-paho-mqtt/APKBUILD8
-rw-r--r--user/py3-paho-mqtt/setup.patch5
2 files changed, 7 insertions, 6 deletions
diff --git a/user/py3-paho-mqtt/APKBUILD b/user/py3-paho-mqtt/APKBUILD
index cda723c76..adc799311 100644
--- a/user/py3-paho-mqtt/APKBUILD
+++ b/user/py3-paho-mqtt/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=py3-paho-mqtt
_pkgname=paho.mqtt.python
-pkgver=1.4.0
+pkgver=1.5.0
pkgrel=0
pkgdesc="MQTT version 3.1.1 client class for Python"
url="https://www.eclipse.org/paho/"
@@ -10,8 +10,8 @@ url="https://www.eclipse.org/paho/"
arch="noarch"
license="EPL-1.0 AND EDL-1.0"
depends="python3"
-makedepends=""
checkdepends="py3-pytest"
+makedepends=""
# Use GitHub tarball since PyPI doesn't include tests
source="$pkgname-$pkgver.tar.gz::https://github.com/eclipse/paho.mqtt.python/archive/v$pkgver.tar.gz
setup.patch"
@@ -29,5 +29,5 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="2e49f0f146207ab4fbc8c346b10d3e2b50869b2d9db7c999b6645f7213fb635b64cff01c5405e7833a8b25334d24685ce6ed734a6e4b6b0660b48f65cf4a941c py3-paho-mqtt-1.4.0.tar.gz
-0cfff826651b36b5062dae8bad3abcab428dc18bfcee6c941a46f5c8900c871bd475d96fa382e06d731ea451ad9159edadf0ee3767f7dea992cb7a7ed7313d80 setup.patch"
+sha512sums="7e52180bf1783ee1f39aa5248730e82fae47fe3db7c4579b0b7207a29f5337c7c0af58d58aac1c265b1ed91fa9c240187d5e3005f55c6e28623e6cbc36750294 py3-paho-mqtt-1.5.0.tar.gz
+690f18379f1d920c9eb63a14dfa1331e8400d95db5a6038df85aaa78756d965a303a5b00877615b1546cefb804994dec99c4067564d899421aceb0e0ad3c3e68 setup.patch"
diff --git a/user/py3-paho-mqtt/setup.patch b/user/py3-paho-mqtt/setup.patch
index 70ccc869f..17a2243a9 100644
--- a/user/py3-paho-mqtt/setup.patch
+++ b/user/py3-paho-mqtt/setup.patch
@@ -1,14 +1,15 @@
--- paho.mqtt.python-1.4.0/setup.py 2018-09-02 11:20:42.000000000 +0000
+++ paho.mqtt.python-1.4.0/setup.py 2019-08-28 02:51:55.690633661 +0000
-@@ -11,9 +11,8 @@ with open('README.rst', 'rb') as readme_
+@@ -11,10 +11,9 @@ with open('README.rst', 'rb') as readme_
readme = readme_file.read().decode('utf-8')
requirements = []
--test_requirements = ['pytest', 'pylama']
+-test_requirements = ['pytest', 'pylama', 'six']
-needs_pytest = {'pytest', 'test', 'ptr'}.intersection(sys.argv)
-setup_requirements = ['pytest-runner'] if needs_pytest else []
+test_requirements = ['pytest']
+setup_requirements = []
+ extra_requirements = {'proxy': ['PySocks']}
if sys.version_info < (3, 0):
test_requirements += ['mock']