summaryrefslogtreecommitdiff
path: root/user/py3-passlib
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-07-17 14:40:58 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-07-17 14:40:58 +0000
commitc097d42b24961dedeec39f688f43982c7b8005ea (patch)
treeb8bb9b2b4ed4894690dd2b3c47e44e5bd57ddbf4 /user/py3-passlib
parent939dfb0e51b44595fda04b94ead447f24b5cc881 (diff)
downloadpackages-c097d42b24961dedeec39f688f43982c7b8005ea.tar.gz
packages-c097d42b24961dedeec39f688f43982c7b8005ea.tar.bz2
packages-c097d42b24961dedeec39f688f43982c7b8005ea.tar.xz
packages-c097d42b24961dedeec39f688f43982c7b8005ea.zip
user/py3-passlib: new package
Diffstat (limited to 'user/py3-passlib')
-rw-r--r--user/py3-passlib/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/user/py3-passlib/APKBUILD b/user/py3-passlib/APKBUILD
new file mode 100644
index 000000000..e3b86d402
--- /dev/null
+++ b/user/py3-passlib/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=py3-passlib
+_pkgname=${pkgname#py3-}
+pkgver=1.7.1
+pkgrel=0
+pkgdesc="Python password hashing framework"
+url="https://pypi.org/project/passlib/"
+arch="noarch"
+options="!check" # needs nose
+license="BSD-3-Clause"
+depends="python3"
+checkdepends="py3-nose"
+makedepends="python3-dev"
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ mkdir -p "$pkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="3d5f069cd4e44e5e87cdabc46845acbdd6c1eeedb7ce1f611aebee87b0f7af19009b6a47a10ec555fd84260b9f5c933c6429e325d30326de3869f05031674168 passlib-1.7.1.tar.gz"