summaryrefslogtreecommitdiff
path: root/user/py3-pluggy/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2018-04-17 02:41:35 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2018-04-17 02:41:35 +0000
commit43b60beb3683582dba2610095c5c0d9fe103ec4c (patch)
treeee2d0852258898f90b9033fc54161c3f90fd8e7d /user/py3-pluggy/APKBUILD
parent8e41995ddbb56175eb00995ab0f7f750e5bde2da (diff)
parent4f4582578d04b74931148cf5a3e4cc6653188bc6 (diff)
downloadpackages-43b60beb3683582dba2610095c5c0d9fe103ec4c.tar.gz
packages-43b60beb3683582dba2610095c5c0d9fe103ec4c.tar.bz2
packages-43b60beb3683582dba2610095c5c0d9fe103ec4c.tar.xz
packages-43b60beb3683582dba2610095c5c0d9fe103ec4c.zip
Merge branch 'meta/tox' into 'master'
Basic python3 testing packages ``` Includes: * user/py3-tox * user/py3-setuptools * user/py3-pluggy * user/py3-virtualenv * user/py3-pytest ** user/py3-py Most of these packages use tox itself for tests, so !check until we have a copy of tox on the mirrors with which to bootstrap. ``` See merge request !16
Diffstat (limited to 'user/py3-pluggy/APKBUILD')
-rw-r--r--user/py3-pluggy/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/user/py3-pluggy/APKBUILD b/user/py3-pluggy/APKBUILD
new file mode 100644
index 000000000..b71d8de07
--- /dev/null
+++ b/user/py3-pluggy/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Max Rees <maxcrees@me.com>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=py3-pluggy
+_pkgname=pluggy
+pkgver=0.6.0
+pkgrel=0
+pkgdesc="Plugin management and hook calling for Python"
+url="https://pypi.python.org/pypi/pluggy"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="python3-dev py3-setuptools"
+#checkdepends="py3-tox"
+options="!check" # Cyclic dependency with py3-tox. Passes on x86_64
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ tox -e py36-pytestrelease
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="dd58dabe2e65eee64d62c8748c2bbd99457288e99b819eb12312f2acdb0740ac46fd08f83522bc992297b9f14eec14c216c2c9688580f68393bf6fc609e65812 py3-pluggy-0.6.0.tar.gz"