summaryrefslogtreecommitdiff
path: root/user/py3-py/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2019-08-08 03:31:00 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2019-08-08 03:31:00 +0000
commita01cc01896f6fb3b472622711d632100b3c86cdb (patch)
tree21fb15bbd40fabb290446ee3aa09e491306f2a87 /user/py3-py/APKBUILD
parent5c572c8c2013c5833d041ea4411a189d85f312fa (diff)
parent3f98aef31c277c4f673d3ad9db6b11b6e973ea5e (diff)
downloadpackages-a01cc01896f6fb3b472622711d632100b3c86cdb.tar.gz
packages-a01cc01896f6fb3b472622711d632100b3c86cdb.tar.bz2
packages-a01cc01896f6fb3b472622711d632100b3c86cdb.tar.xz
packages-a01cc01896f6fb3b472622711d632100b3c86cdb.zip
Merge branch 'sr.2019.08.06' into 'master'
Misc package bumps for Maintainer: Max Rees, 2019.08.06 See merge request adelie/packages!313
Diffstat (limited to 'user/py3-py/APKBUILD')
-rw-r--r--user/py3-py/APKBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/user/py3-py/APKBUILD b/user/py3-py/APKBUILD
index a38f90caf..72f6ee4c1 100644
--- a/user/py3-py/APKBUILD
+++ b/user/py3-py/APKBUILD
@@ -2,35 +2,34 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=py3-py
_pkgname=py
-pkgver=1.7.0
+_p=p
+pkgver=1.8.0
pkgrel=0
pkgdesc="A python library with cross-python path, ini-parsing, io, code, log facilities"
url="https://pypi.python.org/project/py"
arch="noarch"
-options="!checkroot !check" # Circular dependency with py3-pytest. Passes on x86_64
+options="!check" # Circular dependency with py3-pytest.
+# And nobody seems to care about it. (some failures with pytest deprecation)
# Certified net clean
license="MIT"
depends="python3"
makedepends="python3-dev"
#checkdepends="py3-pytest"
-source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz
scm.patch"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
PYTHONPATH="$builddir/build/lib:$PYTHONPATH" pytest
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="c522be926c5716d866cb800eaa398a55518889da207a00575212254642eda2107e68c286e72b99cf94ecec1c8dcde1f763e2d8f296ab7e7673ae2671e70d5548 py3-py-1.7.0.tar.gz
+sha512sums="37b9a66229b834a034d9ba6769a46addf098380b494c1eb863607a52d00b7ec5b9157dd7ac6ffc52535a05006648c775c78716d7f85cf44966065b225be6e95b py3-py-1.8.0.tar.gz
08a1645832d46ffab5b1fb2e7ef480c55a0d4ac266d53857d9ddae5c46ba11232b04bc0cb035bb9e3d08f9d439e844a623340882080555206811fe0624c61bc1 scm.patch"