summaryrefslogtreecommitdiff
path: root/user/py3-py/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2018-10-26 05:20:13 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2018-10-26 05:20:13 +0000
commitc1dbd8de7bf166d167963e3824bd0cb29af37a6a (patch)
tree7940bf4e288a0cd2c0a2c5a6962a01e06c182a81 /user/py3-py/APKBUILD
parent5de1873e1a00b3d4559dc43a654200c5c6d2e72f (diff)
parentd3501fe0983a95540ba0bf2d9811dc583dd592f4 (diff)
downloadpackages-c1dbd8de7bf166d167963e3824bd0cb29af37a6a.tar.gz
packages-c1dbd8de7bf166d167963e3824bd0cb29af37a6a.tar.bz2
packages-c1dbd8de7bf166d167963e3824bd0cb29af37a6a.tar.xz
packages-c1dbd8de7bf166d167963e3824bd0cb29af37a6a.zip
Merge branch 'detoxify' into 'master'
Update some Python packages and drop py3-tox rdeps where unnecessary See merge request !97
Diffstat (limited to 'user/py3-py/APKBUILD')
-rw-r--r--user/py3-py/APKBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/user/py3-py/APKBUILD b/user/py3-py/APKBUILD
index a17fe96d1..a38f90caf 100644
--- a/user/py3-py/APKBUILD
+++ b/user/py3-py/APKBUILD
@@ -2,17 +2,19 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=py3-py
_pkgname=py
-pkgver=1.5.3
+pkgver=1.7.0
pkgrel=0
pkgdesc="A python library with cross-python path, ini-parsing, io, code, log facilities"
url="https://pypi.python.org/project/py"
arch="noarch"
-options="!check" # Circular dependency with py3-tox. Passes on x86_64
+options="!checkroot !check" # Circular dependency with py3-pytest. Passes on x86_64
+# Certified net clean
license="MIT"
depends="python3"
makedepends="python3-dev"
-#checkdepends="py3-tox"
-source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+#checkdepends="py3-pytest"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ scm.patch"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
@@ -21,10 +23,8 @@ build() {
}
check() {
- # Can't use py3-pytest > 3.0 as of py3-py==1.5.3-r0 because some tests
- # haven't been updated yet
cd "$builddir"
- tox -e py36-pytest30
+ PYTHONPATH="$builddir/build/lib:$PYTHONPATH" pytest
}
package() {
@@ -32,4 +32,5 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="243c0da94c439163257c525ef00b30fd6d8add5897121ee0b1f19476b50f18823ce2b99a5ab27a9cf47598b538758d0534060123dce0820d2a65d98046548c96 py3-py-1.5.3.tar.gz"
+sha512sums="c522be926c5716d866cb800eaa398a55518889da207a00575212254642eda2107e68c286e72b99cf94ecec1c8dcde1f763e2d8f296ab7e7673ae2671e70d5548 py3-py-1.7.0.tar.gz
+08a1645832d46ffab5b1fb2e7ef480c55a0d4ac266d53857d9ddae5c46ba11232b04bc0cb035bb9e3d08f9d439e844a623340882080555206811fe0624c61bc1 scm.patch"