summaryrefslogtreecommitdiff
path: root/user/py3-py
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2018-01-10 18:06:33 +0000
committerMax Rees <maxcrees@me.com>2018-01-11 04:38:50 +0000
commit12c7414dfb3ca6657afa22df4a69579c7d4f2f6d (patch)
tree11d1c2d49c3424259ebd99b89dca603fef3a3c6b /user/py3-py
parentcee386a7d341f6ad530f58bd7ec2785b935cda79 (diff)
downloadpackages-12c7414dfb3ca6657afa22df4a69579c7d4f2f6d.tar.gz
packages-12c7414dfb3ca6657afa22df4a69579c7d4f2f6d.tar.bz2
packages-12c7414dfb3ca6657afa22df4a69579c7d4f2f6d.tar.xz
packages-12c7414dfb3ca6657afa22df4a69579c7d4f2f6d.zip
user/py3-py: new package
Diffstat (limited to 'user/py3-py')
-rw-r--r--user/py3-py/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/user/py3-py/APKBUILD b/user/py3-py/APKBUILD
new file mode 100644
index 000000000..171ac8245
--- /dev/null
+++ b/user/py3-py/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Max Rees <maxcrees@me.com>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=py3-py
+_pkgname=py
+pkgver=1.4.34
+pkgrel=0
+pkgdesc="A python library with cross-python path, ini-parsing, io, code, log facilities"
+url="https://pypi.python.org/py/$pkgver"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="python3-dev py3-setuptools"
+#checkdepends="py3-tox"
+options="!check" # Circular dependency with py3-tox. Passes on x86_64
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ # This test suite seems to be incurring the wrath of
+ # https://bugs.python.org/issue28627 on 1.5.2
+ cd "$builddir"
+ tox -e py36
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="2e19c82c8315274bffe0ba2c7e20ae3af95f942c40c16121ec953af186f8ff33e8f427c070e137bb04b7cc6dcc6779e35df3911c08595fd3294b5ec9897706e1 py3-py-1.4.34.tar.gz"