summaryrefslogtreecommitdiff
path: root/user/py3-py
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-01-11 21:36:39 +0000
committerZach van Rijn <me@zv.io>2022-10-21 18:33:57 -0500
commit7e6c4c26fa4b95fe165a24c022a01c9fc05e73bc (patch)
tree931e6d5cfddd191e983aa19b89af1de597f68646 /user/py3-py
parent3e3aa629a86fab53f434e0a5a87926b0856ccd7b (diff)
downloadpackages-7e6c4c26fa4b95fe165a24c022a01c9fc05e73bc.tar.gz
packages-7e6c4c26fa4b95fe165a24c022a01c9fc05e73bc.tar.bz2
packages-7e6c4c26fa4b95fe165a24c022a01c9fc05e73bc.tar.xz
packages-7e6c4c26fa4b95fe165a24c022a01c9fc05e73bc.zip
user/py3-*: bunch of new py3 packages and updates. fixes #458, #459.
Diffstat (limited to 'user/py3-py')
-rw-r--r--user/py3-py/APKBUILD8
-rw-r--r--user/py3-py/scm.patch12
2 files changed, 3 insertions, 17 deletions
diff --git a/user/py3-py/APKBUILD b/user/py3-py/APKBUILD
index 72f6ee4c1..6c1912664 100644
--- a/user/py3-py/APKBUILD
+++ b/user/py3-py/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-py
_pkgname=py
_p=p
-pkgver=1.8.0
+pkgver=1.11.0
pkgrel=0
pkgdesc="A python library with cross-python path, ini-parsing, io, code, log facilities"
url="https://pypi.python.org/project/py"
@@ -15,8 +15,7 @@ license="MIT"
depends="python3"
makedepends="python3-dev"
#checkdepends="py3-pytest"
-source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz
- scm.patch"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
@@ -31,5 +30,4 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="37b9a66229b834a034d9ba6769a46addf098380b494c1eb863607a52d00b7ec5b9157dd7ac6ffc52535a05006648c775c78716d7f85cf44966065b225be6e95b py3-py-1.8.0.tar.gz
-08a1645832d46ffab5b1fb2e7ef480c55a0d4ac266d53857d9ddae5c46ba11232b04bc0cb035bb9e3d08f9d439e844a623340882080555206811fe0624c61bc1 scm.patch"
+sha512sums="ce8dd791f9f6dd7e60a6caad32ff5cb816389a0840436efdedf4e0d4b0bfa09f7aea9e7c31d89903c72fe6ef17170a85af480525ba92c458ed73501a0420f2c4 py3-py-1.11.0.tar.gz"
diff --git a/user/py3-py/scm.patch b/user/py3-py/scm.patch
deleted file mode 100644
index 44665748f..000000000
--- a/user/py3-py/scm.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- py-1.7.0/setup.py 2018-08-27 20:39:51.000000000 +0000
-+++ py-1.7.0/setup.py 2018-10-11 05:07:12.560247181 +0000
-@@ -6,8 +6,7 @@ def main():
- name='py',
- description='library with cross-python path, ini-parsing, io, code, log facilities',
- long_description=open('README.rst').read(),
-- use_scm_version={"write_to": "py/_version.py"},
-- setup_requires=["setuptools-scm"],
-+ version='1.7.0',
- url='http://py.readthedocs.io/',
- license='MIT license',
- platforms=['unix', 'linux', 'osx', 'cygwin', 'win32'],