summaryrefslogtreecommitdiff
path: root/user/py3-py
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2019-08-06 04:32:02 -0500
committerMax Rees <maxcrees@me.com>2019-08-06 04:32:02 -0500
commitee3fa0e95d09e1a90a9157f184b877c90e0be4d8 (patch)
treee9ff835e0685e60c7f2b26469001b0291304856c /user/py3-py
parentcb9126e4b89c826c988a4d860198e6958fe5f3a8 (diff)
downloadpackages-ee3fa0e95d09e1a90a9157f184b877c90e0be4d8.tar.gz
packages-ee3fa0e95d09e1a90a9157f184b877c90e0be4d8.tar.bz2
packages-ee3fa0e95d09e1a90a9157f184b877c90e0be4d8.tar.xz
packages-ee3fa0e95d09e1a90a9157f184b877c90e0be4d8.zip
user/py3-py: bump to 1.8.0
Diffstat (limited to 'user/py3-py')
-rw-r--r--user/py3-py/APKBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/user/py3-py/APKBUILD b/user/py3-py/APKBUILD
index a38f90caf..72f6ee4c1 100644
--- a/user/py3-py/APKBUILD
+++ b/user/py3-py/APKBUILD
@@ -2,35 +2,34 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=py3-py
_pkgname=py
-pkgver=1.7.0
+_p=p
+pkgver=1.8.0
pkgrel=0
pkgdesc="A python library with cross-python path, ini-parsing, io, code, log facilities"
url="https://pypi.python.org/project/py"
arch="noarch"
-options="!checkroot !check" # Circular dependency with py3-pytest. Passes on x86_64
+options="!check" # Circular dependency with py3-pytest.
+# And nobody seems to care about it. (some failures with pytest deprecation)
# Certified net clean
license="MIT"
depends="python3"
makedepends="python3-dev"
#checkdepends="py3-pytest"
-source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz
scm.patch"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
PYTHONPATH="$builddir/build/lib:$PYTHONPATH" pytest
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="c522be926c5716d866cb800eaa398a55518889da207a00575212254642eda2107e68c286e72b99cf94ecec1c8dcde1f763e2d8f296ab7e7673ae2671e70d5548 py3-py-1.7.0.tar.gz
+sha512sums="37b9a66229b834a034d9ba6769a46addf098380b494c1eb863607a52d00b7ec5b9157dd7ac6ffc52535a05006648c775c78716d7f85cf44966065b225be6e95b py3-py-1.8.0.tar.gz
08a1645832d46ffab5b1fb2e7ef480c55a0d4ac266d53857d9ddae5c46ba11232b04bc0cb035bb9e3d08f9d439e844a623340882080555206811fe0624c61bc1 scm.patch"