summaryrefslogtreecommitdiff
path: root/user/py3-pycotap
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-10-18 03:09:28 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-10-18 03:09:28 +0000
commit911ef46e23e657dd28746c4227a2b2fd0af34298 (patch)
treeeda332663ff87e8b99ab638329159f8fbdcb7a34 /user/py3-pycotap
parent0315cf55260aec4634379e4e9251b706c567c853 (diff)
downloadpackages-911ef46e23e657dd28746c4227a2b2fd0af34298.tar.gz
packages-911ef46e23e657dd28746c4227a2b2fd0af34298.tar.bz2
packages-911ef46e23e657dd28746c4227a2b2fd0af34298.tar.xz
packages-911ef46e23e657dd28746c4227a2b2fd0af34298.zip
user/py3-pycotap: new package
Diffstat (limited to 'user/py3-pycotap')
-rw-r--r--user/py3-pycotap/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/user/py3-pycotap/APKBUILD b/user/py3-pycotap/APKBUILD
new file mode 100644
index 000000000..a2731dc39
--- /dev/null
+++ b/user/py3-pycotap/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=py3-pycotap
+_pipname=pycotap
+pkgver=1.1.0
+pkgrel=0
+pkgdesc="Tiny Python test runner that outputs TAP results"
+url="https://el-tramo.be/pycotap/"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/a1/99/f1dfa70ffe1140f701ba9797630fb12c12558c28865e1e01728800054d32/pycotap-$pkgver.tar.gz"
+builddir="$srcdir/$_pipname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="dbe8d76c3e4b934dd4ff9ec0d48caafef3ae5583046a7316607b3c8cebf8cb920c68dc46487243aac81823994805c76f2be8ff0cbda593c70b70f268661fa289 pycotap-1.1.0.tar.gz"