summaryrefslogtreecommitdiff
path: root/user/py3-pytest/scm.patch
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2019-08-06 08:29:17 -0500
committerMax Rees <maxcrees@me.com>2019-08-06 08:31:08 -0500
commit3350abe8925d99bc448b9c190c94ff13b84a7625 (patch)
tree63883e8b660445721ce14a14d16798b2fd917db3 /user/py3-pytest/scm.patch
parent72bedd94956da15e9ddee28d50e071253922c0da (diff)
downloadpackages-3350abe8925d99bc448b9c190c94ff13b84a7625.tar.gz
packages-3350abe8925d99bc448b9c190c94ff13b84a7625.tar.bz2
packages-3350abe8925d99bc448b9c190c94ff13b84a7625.tar.xz
packages-3350abe8925d99bc448b9c190c94ff13b84a7625.zip
user/py3-pytest: bump to 5.0.1
Diffstat (limited to 'user/py3-pytest/scm.patch')
-rw-r--r--user/py3-pytest/scm.patch19
1 files changed, 9 insertions, 10 deletions
diff --git a/user/py3-pytest/scm.patch b/user/py3-pytest/scm.patch
index 799eefac0..ef45821cd 100644
--- a/user/py3-pytest/scm.patch
+++ b/user/py3-pytest/scm.patch
@@ -1,13 +1,12 @@
---- pytest-3.9.1/setup.py 2018-10-16 15:46:37.000000000 -0400
-+++ pytest-3.9.1/setup.py 2018-10-22 19:32:49.261592294 -0400
-@@ -25,8 +25,8 @@ if "_PYTEST_SETUP_SKIP_PLUGGY_DEP" not i
-
+--- pytest-5.0.1/setup.py 2019-07-05 07:12:59.000000000 -0400
++++ pytest-5.0.1/setup.py 2019-08-06 08:09:07.890005143 -0400
+@@ -19,7 +19,8 @@ INSTALL_REQUIRES = [
def main():
setup(
-- use_scm_version={"write_to": "src/_pytest/_version.py"},
-- setup_requires=["setuptools-scm", "setuptools>=30.3"],
-+ setup_requires=["setuptools>=30.3"],
-+ version="3.9.1",
+ use_scm_version={"write_to": "src/_pytest/_version.py"},
+- setup_requires=["setuptools-scm", "setuptools>=40.0"],
++ setup_requires=["setuptools>=40.0"],
++ version="5.0.1",
package_dir={"": "src"},
- install_requires=INSTALL_REQUIRES,
- )
+ # fmt: off
+ extras_require={