summaryrefslogtreecommitdiff
path: root/user/py3-pytest/scm.patch
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2018-10-26 05:20:13 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2018-10-26 05:20:13 +0000
commitc1dbd8de7bf166d167963e3824bd0cb29af37a6a (patch)
tree7940bf4e288a0cd2c0a2c5a6962a01e06c182a81 /user/py3-pytest/scm.patch
parent5de1873e1a00b3d4559dc43a654200c5c6d2e72f (diff)
parentd3501fe0983a95540ba0bf2d9811dc583dd592f4 (diff)
downloadpackages-c1dbd8de7bf166d167963e3824bd0cb29af37a6a.tar.gz
packages-c1dbd8de7bf166d167963e3824bd0cb29af37a6a.tar.bz2
packages-c1dbd8de7bf166d167963e3824bd0cb29af37a6a.tar.xz
packages-c1dbd8de7bf166d167963e3824bd0cb29af37a6a.zip
Merge branch 'detoxify' into 'master'
Update some Python packages and drop py3-tox rdeps where unnecessary See merge request !97
Diffstat (limited to 'user/py3-pytest/scm.patch')
-rw-r--r--user/py3-pytest/scm.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/user/py3-pytest/scm.patch b/user/py3-pytest/scm.patch
new file mode 100644
index 000000000..799eefac0
--- /dev/null
+++ b/user/py3-pytest/scm.patch
@@ -0,0 +1,13 @@
+--- pytest-3.9.1/setup.py 2018-10-16 15:46:37.000000000 -0400
++++ pytest-3.9.1/setup.py 2018-10-22 19:32:49.261592294 -0400
+@@ -25,8 +25,8 @@ if "_PYTEST_SETUP_SKIP_PLUGGY_DEP" not i
+
+ def main():
+ setup(
+- use_scm_version={"write_to": "src/_pytest/_version.py"},
+- setup_requires=["setuptools-scm", "setuptools>=30.3"],
++ setup_requires=["setuptools>=30.3"],
++ version="3.9.1",
+ package_dir={"": "src"},
+ install_requires=INSTALL_REQUIRES,
+ )