summaryrefslogtreecommitdiff
path: root/user/py3-pytest
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-01-11 21:14:55 +0000
committerZach van Rijn <me@zv.io>2022-10-21 18:33:57 -0500
commit3e3aa629a86fab53f434e0a5a87926b0856ccd7b (patch)
tree70e405e4d597215bbebcc95b78113527709e832e /user/py3-pytest
parent01021113cc1a1e0f9783e9c7dda12ac1512605c1 (diff)
downloadpackages-3e3aa629a86fab53f434e0a5a87926b0856ccd7b.tar.gz
packages-3e3aa629a86fab53f434e0a5a87926b0856ccd7b.tar.bz2
packages-3e3aa629a86fab53f434e0a5a87926b0856ccd7b.tar.xz
packages-3e3aa629a86fab53f434e0a5a87926b0856ccd7b.zip
user/py3-pytest: bump { 5.2.0 --> 6.2.5 }. fixes #458.
Diffstat (limited to 'user/py3-pytest')
-rw-r--r--user/py3-pytest/APKBUILD8
-rw-r--r--user/py3-pytest/scm.patch12
2 files changed, 3 insertions, 17 deletions
diff --git a/user/py3-pytest/APKBUILD b/user/py3-pytest/APKBUILD
index e3d733947..498158366 100644
--- a/user/py3-pytest/APKBUILD
+++ b/user/py3-pytest/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=py3-pytest
_pkgname=pytest
-pkgver=5.2.0
+pkgver=6.2.5
pkgrel=0
pkgdesc="A python test library"
url="https://pypi.python.org/pypi/pytest"
@@ -14,8 +14,7 @@ depends="python3 py3-atomicwrites py3-attrs py3-more-itertools
py3-packaging py3-pluggy py3-py py3-six py3-wcwidth"
makedepends="python3-dev"
checkdepends="py3-pytest py3-hypothesis"
-source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz
- scm.patch"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
@@ -32,5 +31,4 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="5c766c263cdafb5e1cdb65d883ac7f5b50da14356b074448f8458e78eda8916190142dbaf7006235c02647d600e40851848e5905df17f8dff0a9fb02a90bd78d py3-pytest-5.2.0.tar.gz
-6c597ec2416017ebc0bf2e9df338234e3ab8ca187242bab2b8f411316cc04f3c29a9a939faab349b8201043c7c16ceefe614349793e2010e62f16d9e7aefa05f scm.patch"
+sha512sums="7624563a9d967da4cbf82cfff90bae8c0cca07b32e291dc7c5efa787725ed1a255edd066bf0d5fbd89b8cbed8cf5b619fe7c7017f44a7f8a014e3310c06bdbf9 py3-pytest-6.2.5.tar.gz"
diff --git a/user/py3-pytest/scm.patch b/user/py3-pytest/scm.patch
deleted file mode 100644
index e3b923f1d..000000000
--- a/user/py3-pytest/scm.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- pytest-5.0.1/setup.py 2019-07-05 07:12:59.000000000 -0400
-+++ pytest-5.0.1/setup.py 2019-08-06 08:09:07.890005143 -0400
-@@ -19,7 +19,8 @@ INSTALL_REQUIRES = [
- def main():
- setup(
- use_scm_version={"write_to": "src/_pytest/_version.py"},
-- setup_requires=["setuptools-scm", "setuptools>=40.0"],
-+ setup_requires=["setuptools>=40.0"],
-+ version="5.2.0",
- package_dir={"": "src"},
- # fmt: off
- extras_require={