summaryrefslogtreecommitdiff
path: root/user/py3-pytest
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2018-09-15 23:41:33 -0400
committerMax Rees <maxcrees@me.com>2018-09-17 15:51:25 -0400
commit9122dc3237518aadf0f67473121320c38f6018b5 (patch)
tree0350fea681d2aa74aea4980ea420d3ac05c096c5 /user/py3-pytest
parent5c620e978b63c54067156fbce424034923f1358c (diff)
downloadpackages-9122dc3237518aadf0f67473121320c38f6018b5.tar.gz
packages-9122dc3237518aadf0f67473121320c38f6018b5.tar.bz2
packages-9122dc3237518aadf0f67473121320c38f6018b5.tar.xz
packages-9122dc3237518aadf0f67473121320c38f6018b5.zip
user/py3-pytest: add undeclared dependencies and disable circular ones
Diffstat (limited to 'user/py3-pytest')
-rw-r--r--user/py3-pytest/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/user/py3-pytest/APKBUILD b/user/py3-pytest/APKBUILD
index 30a26fb30..8d720971e 100644
--- a/user/py3-pytest/APKBUILD
+++ b/user/py3-pytest/APKBUILD
@@ -3,13 +3,13 @@
pkgname=py3-pytest
_pkgname=pytest
pkgver=3.5.1
-pkgrel=0
+pkgrel=1
pkgdesc="A python test library"
url="https://pypi.python.org/pypi/pytest"
arch="noarch"
options="net !check" # Circular dependency with py3-tox. Passes on x86_64
license="MIT"
-depends="python3 py3-py"
+depends="python3 py3-py py3-more-itertools py3-six py3-pluggy py3-attrs"
makedepends="python3-dev"
#checkdepends="py3-tox"
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"