summaryrefslogtreecommitdiff
path: root/user/py3-python-dateutil
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-26 21:37:37 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-26 21:37:37 -0600
commitb65d572bc23d04bd90823e4d3a6a5770ea85a4f7 (patch)
treec8f0ace47af6cbbdefd906656efa02285686d5bd /user/py3-python-dateutil
parent98571c8ae21a79bae5c09cfa11836b7d43b7cfcd (diff)
downloadpackages-b65d572bc23d04bd90823e4d3a6a5770ea85a4f7.tar.gz
packages-b65d572bc23d04bd90823e4d3a6a5770ea85a4f7.tar.bz2
packages-b65d572bc23d04bd90823e4d3a6a5770ea85a4f7.tar.xz
packages-b65d572bc23d04bd90823e4d3a6a5770ea85a4f7.zip
user/py3-python-dateutil: fix testing on newer PyTest versions
Diffstat (limited to 'user/py3-python-dateutil')
-rw-r--r--user/py3-python-dateutil/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/user/py3-python-dateutil/APKBUILD b/user/py3-python-dateutil/APKBUILD
index 56e7075e8..833c61ed2 100644
--- a/user/py3-python-dateutil/APKBUILD
+++ b/user/py3-python-dateutil/APKBUILD
@@ -18,17 +18,17 @@ source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
- pytest
+ # Required with PyTest >=4.8, see:
+ # https://bugzilla.redhat.com/show_bug.cgi?id=1734775
+ # https://github.com/pytest-dev/pytest/issues/5678
+ pytest -W ignore::pytest.PytestUnknownMarkWarning
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}