summaryrefslogtreecommitdiff
path: root/user/py3-pyyaml/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2019-03-18 18:54:42 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2019-03-18 18:54:42 +0000
commit32c38901a3117b823697bdcd7adafec4607912d6 (patch)
tree23f9d3ffcaf5505c086cd4f0ca026f58b08fec38 /user/py3-pyyaml/APKBUILD
parent40254b068b9389c30608184e33ffce42ee3fc74c (diff)
parent86bc7fce4c621370283feab618a2911c365d5deb (diff)
downloadpackages-32c38901a3117b823697bdcd7adafec4607912d6.tar.gz
packages-32c38901a3117b823697bdcd7adafec4607912d6.tar.bz2
packages-32c38901a3117b823697bdcd7adafec4607912d6.tar.xz
packages-32c38901a3117b823697bdcd7adafec4607912d6.zip
Merge branch 'zlg.2019-03' into 'master'
zlg's package bumps for March 2019 This is a routine package upgrade. There is one thing to note, however: * `py3-pyyaml` has a minor issue building due to a missing `ext/_yaml.c` file. It appears that a tool is used to generate the `.c` file it needs to compile the module. It falls back to pure-Python mode and passes all tests, however. I hand-tested `py3-pyyaml` by using vgstash to export a game collection to yaml (everything worked fine) and received a test cert from `certbot` to confirm the bumps didn't break anything affected on my system, since they're the two largest consumers of what was bumped. This should be the last version bump from me until post-1.0-BETA3, barring security bumps. See merge request !202
Diffstat (limited to 'user/py3-pyyaml/APKBUILD')
-rw-r--r--user/py3-pyyaml/APKBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/user/py3-pyyaml/APKBUILD b/user/py3-pyyaml/APKBUILD
index 8af1d75f1..6dece19c3 100644
--- a/user/py3-pyyaml/APKBUILD
+++ b/user/py3-pyyaml/APKBUILD
@@ -1,21 +1,23 @@
# Contributor: zlg <zlg+adelie@zlg.space>
# Maintainer: zlg <zlg+adelie@zlg.space>
pkgname=py3-pyyaml
-_pkgname=PyYAML
-pkgver=3.13
+_pkgname=pyyaml
+pkgver=5.1
pkgrel=0
pkgdesc="YAML parser and emitter for Python"
url="https://pyyaml.org/wiki/PyYAML"
-arch="all"
+arch="noarch"
license="MIT"
depends="python3 yaml"
makedepends="python3-dev yaml yaml-dev"
subpackages=""
-source="http://pyyaml.org/download/pyyaml/$_pkgname-$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/yaml/$_pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
cd "$builddir"
+ # Seems like they need Cython to build the C extension now, so it falls back to pure Python.
+ # Once we ship Cython we can probably change this.
python3 setup.py build
}
@@ -29,4 +31,4 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="93642286d0317e2fe970632c36d38ce6030f7cabcf971f28e3a1054f07390fcee5baaf7f167e7c9690dbd7b2adc61f5b7d75a218ace0abca34ff8815486cfdd7 PyYAML-3.13.tar.gz"
+sha512sums="e49f593b9f60018efa19629b902ad1e56f79537106a4cd019baa324a74a8af7563d294db012280261fc7fa9d686dd5af656e22fb4bf6a6ccfd0084515b9591d5 py3-pyyaml-5.1.tar.gz"