summaryrefslogtreecommitdiff
path: root/user/py3-roman
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2018-01-08 03:25:37 +0000
committerMax Rees <maxcrees@me.com>2018-01-11 04:23:26 +0000
commit4acd1ae4efea6ab5beae48e4d9626cf67415f80b (patch)
tree3a632da97a5c99bbe802b5927d6f3b98572e5065 /user/py3-roman
parentcee386a7d341f6ad530f58bd7ec2785b935cda79 (diff)
downloadpackages-4acd1ae4efea6ab5beae48e4d9626cf67415f80b.tar.gz
packages-4acd1ae4efea6ab5beae48e4d9626cf67415f80b.tar.bz2
packages-4acd1ae4efea6ab5beae48e4d9626cf67415f80b.tar.xz
packages-4acd1ae4efea6ab5beae48e4d9626cf67415f80b.zip
user/py3-roman: new package
Diffstat (limited to 'user/py3-roman')
-rw-r--r--user/py3-roman/APKBUILD35
-rw-r--r--user/py3-roman/py36.patch10
2 files changed, 45 insertions, 0 deletions
diff --git a/user/py3-roman/APKBUILD b/user/py3-roman/APKBUILD
new file mode 100644
index 000000000..ce00a3785
--- /dev/null
+++ b/user/py3-roman/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Max Rees <maxcrees@me.com>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=py3-roman
+_pkgname=roman
+pkgver=2.0.0
+pkgrel=2
+pkgdesc="Python library to convert integers to Roman numerals"
+url="http://pypi.python.org/pypi/roman"
+arch="noarch"
+license="Python-2.1.1" # not SPDX
+depends="python3"
+makedepends="python3-dev py3-setuptools unzip"
+checkdepends="py3-tox"
+source="$pkgname-$pkgver.zip::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip
+ py36.patch"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ # Do not bootstrap - tries to access web
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ tox -e py36
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="d62a95e835232821dbf7a81d0c6b7df63f18c4116cfc7eee0c691a0b31d3d7b69d2dc2e4ea26e0a169a8e24bf080e8bb1e195b853be4adf1491335a5b4d5702c py3-roman-2.0.0.zip
+8f6bfe0f7259db6091b71c8744592de34ca305a30b5ac44cb366fd3e71ebbead21b892939a15b19cd0e344445f981f16ae493bb70ade171b2ba1d92daa431931 py36.patch"
diff --git a/user/py3-roman/py36.patch b/user/py3-roman/py36.patch
new file mode 100644
index 000000000..fc74674a7
--- /dev/null
+++ b/user/py3-roman/py36.patch
@@ -0,0 +1,10 @@
+--- roman-2.0.0/tox.ini 2013-02-25 10:15:52.000000000 +0000
++++ roman-2.0.0/tox.ini 2018-01-11 02:04:11.950000000 +0000
+@@ -1,6 +1,6 @@
+ [tox]
+ envlist =
+- py26,py27,py33,pypy
++ py26,py27,py33,pypy,py36
+
+ [testenv]
+ commands =