summaryrefslogtreecommitdiff
path: root/user/py3-setuptools/APKBUILD
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2018-01-08 03:05:58 +0000
committerMax Rees <maxcrees@me.com>2018-01-11 02:51:42 +0000
commit5a80174ae5ca8624d60b61d5dae0f45caffed042 (patch)
treeca3ed07a317eb21721d322e1bdcc240a3a4185be /user/py3-setuptools/APKBUILD
parentcee386a7d341f6ad530f58bd7ec2785b935cda79 (diff)
downloadpackages-5a80174ae5ca8624d60b61d5dae0f45caffed042.tar.gz
packages-5a80174ae5ca8624d60b61d5dae0f45caffed042.tar.bz2
packages-5a80174ae5ca8624d60b61d5dae0f45caffed042.tar.xz
packages-5a80174ae5ca8624d60b61d5dae0f45caffed042.zip
user/py3-setuptools: new package
Diffstat (limited to 'user/py3-setuptools/APKBUILD')
-rw-r--r--user/py3-setuptools/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/user/py3-setuptools/APKBUILD b/user/py3-setuptools/APKBUILD
new file mode 100644
index 000000000..ba5e1aebf
--- /dev/null
+++ b/user/py3-setuptools/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Max Rees <maxcrees@me.com>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=py3-setuptools
+_pkgname=setuptools
+pkgver=38.4.0
+pkgrel=1
+pkgdesc="A collection of enhancements to the Python distutils"
+url="http://pypi.python.org/pypi/setuptools"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="python3-dev"
+#checkdepends="py3-tox"
+options="!check" # Circular dependency with py3-tox. Passes on x86_64
+subpackages="py3-easy_install:easy_install"
+# Note: PyPI download is missing tests/requirements.txt
+source="$pkgname-$pkgver.tar.gz::https://github.com/pypa/$_pkgname/archive/v$pkgver.tar.gz
+ pythonpath.patch"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 bootstrap.py
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ PYTHONPATH="$builddir" TOXENV="py36" tox
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+easy_install() {
+ pkgdesc="Python easy_install tool (deprecated)"
+ depends="$pkgname python3"
+ mkdir -p "$subpkgdir/usr/bin"
+ mv "$pkgdir"/usr/bin/easy_install* "$subpkgdir/usr/bin"
+}
+
+sha512sums="81903ee7ecb19715bbafe7b4e6878d3af5f801a9ff3334e82a599a81a8e6430443c4b765180c53c3c9cdcea338b3fff0bdf26245bc9d2da7d5d41b745de73a24 py3-setuptools-38.4.0.tar.gz
+0c80433534dbb715829f48713690a72a68f6cb7e337215c9aa507df0fbb2a2a242f54d42fab848c6f03729f155dfe0ccb819a6f5d5230e2195e94e20094eec0b pythonpath.patch"