summaryrefslogtreecommitdiff
path: root/user/py3-sphinxcontrib-asyncio/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2019-07-22 19:43:53 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2019-07-22 19:43:53 +0000
commitb7ffaa4d55e1faf4de0f8e6a2edf372fedfeaf71 (patch)
tree5948e97345062a759a5ab8d355b0b49849abcfcf /user/py3-sphinxcontrib-asyncio/APKBUILD
parentd61220e97e3a4fec8c1e43970cb1408f790c2c2e (diff)
parent6bd200ed124893c95fda0335b684b26eba0bb743 (diff)
downloadpackages-b7ffaa4d55e1faf4de0f8e6a2edf372fedfeaf71.tar.gz
packages-b7ffaa4d55e1faf4de0f8e6a2edf372fedfeaf71.tar.bz2
packages-b7ffaa4d55e1faf4de0f8e6a2edf372fedfeaf71.tar.xz
packages-b7ffaa4d55e1faf4de0f8e6a2edf372fedfeaf71.zip
Merge branch 'bashisms' into 'master'
Purge bashisms, adduser, and addgroup from packages.git See merge request adelie/packages!293
Diffstat (limited to 'user/py3-sphinxcontrib-asyncio/APKBUILD')
-rw-r--r--user/py3-sphinxcontrib-asyncio/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/user/py3-sphinxcontrib-asyncio/APKBUILD b/user/py3-sphinxcontrib-asyncio/APKBUILD
index 73056c35a..09f91c27b 100644
--- a/user/py3-sphinxcontrib-asyncio/APKBUILD
+++ b/user/py3-sphinxcontrib-asyncio/APKBUILD
@@ -2,6 +2,8 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=py3-sphinxcontrib-asyncio
_pkgname=${pkgname#py3-}
+_p="${_pkgname#?}"
+_p="${_pkgname%"$_p"}"
pkgver=0.2.0
pkgrel=0
pkgdesc="Sphinx extension for using asyncio coroutines in markup"
@@ -13,7 +15,7 @@ depends="python3"
checkdepends="py3-pytest"
makedepends="python3-dev"
subpackages=""
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+source="https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {