summaryrefslogtreecommitdiff
path: root/user/py3-sphinxcontrib-htmlhelp/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2019-07-22 19:43:53 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2019-07-22 19:43:53 +0000
commitb7ffaa4d55e1faf4de0f8e6a2edf372fedfeaf71 (patch)
tree5948e97345062a759a5ab8d355b0b49849abcfcf /user/py3-sphinxcontrib-htmlhelp/APKBUILD
parentd61220e97e3a4fec8c1e43970cb1408f790c2c2e (diff)
parent6bd200ed124893c95fda0335b684b26eba0bb743 (diff)
downloadpackages-b7ffaa4d55e1faf4de0f8e6a2edf372fedfeaf71.tar.gz
packages-b7ffaa4d55e1faf4de0f8e6a2edf372fedfeaf71.tar.bz2
packages-b7ffaa4d55e1faf4de0f8e6a2edf372fedfeaf71.tar.xz
packages-b7ffaa4d55e1faf4de0f8e6a2edf372fedfeaf71.zip
Merge branch 'bashisms' into 'master'
Purge bashisms, adduser, and addgroup from packages.git See merge request adelie/packages!293
Diffstat (limited to 'user/py3-sphinxcontrib-htmlhelp/APKBUILD')
-rw-r--r--user/py3-sphinxcontrib-htmlhelp/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/user/py3-sphinxcontrib-htmlhelp/APKBUILD b/user/py3-sphinxcontrib-htmlhelp/APKBUILD
index 66e2da105..1e5f428d6 100644
--- a/user/py3-sphinxcontrib-htmlhelp/APKBUILD
+++ b/user/py3-sphinxcontrib-htmlhelp/APKBUILD
@@ -2,6 +2,8 @@
# Maintainer: Brandon Bergren <git@bdragon.rtk0.net>
pkgname=py3-sphinxcontrib-htmlhelp
_pkgname=sphinxcontrib-htmlhelp
+_p="${_pkgname#?}"
+_p="${_pkgname%"$_p"}"
pkgver=1.0.1
pkgrel=0
pkgdesc="A sphinx extension to output HtmlHelp"
@@ -12,7 +14,7 @@ license="BSD-2-Clause"
depends="python3"
makedepends="python3-dev"
checkdepends="py3-sphinx py3-pytest py3-html5lib"
-source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {