summaryrefslogtreecommitdiff
path: root/user/py3-sphinxcontrib-htmlhelp/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2019-04-07 14:45:15 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2019-04-07 14:45:15 +0000
commitc5f8a52a58247448855b0b81bae867e5ab31cfef (patch)
tree303ca612dd27096250f7e9d3e6ad739f2dd2ef11 /user/py3-sphinxcontrib-htmlhelp/APKBUILD
parent94628432b84d6c739deab02e7ed9a532f517a686 (diff)
parent64d7aa8301c599bf348897882e50f2a94d7b60df (diff)
downloadpackages-c5f8a52a58247448855b0b81bae867e5ab31cfef.tar.gz
packages-c5f8a52a58247448855b0b81bae867e5ab31cfef.tar.bz2
packages-c5f8a52a58247448855b0b81bae867e5ab31cfef.tar.xz
packages-c5f8a52a58247448855b0b81bae867e5ab31cfef.zip
Merge branch 'py3-sphinx' into 'master'
Add py3-sphinx and its dependencies. This will be needed in the future to build qemu-doc for qemu 4.0. See merge request !214
Diffstat (limited to 'user/py3-sphinxcontrib-htmlhelp/APKBUILD')
-rw-r--r--user/py3-sphinxcontrib-htmlhelp/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/user/py3-sphinxcontrib-htmlhelp/APKBUILD b/user/py3-sphinxcontrib-htmlhelp/APKBUILD
new file mode 100644
index 000000000..66e2da105
--- /dev/null
+++ b/user/py3-sphinxcontrib-htmlhelp/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Brandon Bergren <git@bdragon.rtk0.net>
+# Maintainer: Brandon Bergren <git@bdragon.rtk0.net>
+pkgname=py3-sphinxcontrib-htmlhelp
+_pkgname=sphinxcontrib-htmlhelp
+pkgver=1.0.1
+pkgrel=0
+pkgdesc="A sphinx extension to output HtmlHelp"
+url="https://pypi.python.org/pypi/sphinxcontrib-htmlhelp"
+arch="noarch"
+options="!check" # Cyclic dependency with sphinx
+license="BSD-2-Clause"
+depends="python3"
+makedepends="python3-dev"
+checkdepends="py3-sphinx py3-pytest py3-html5lib"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ PYTHONWARNINGS="all,ignore::DeprecationWarning:docutils.io" pytest --durations 25
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+
+}
+
+sha512sums="a364a490e5043e767a8b498b5b621f3f3c64bf15f65847097489d3d2ba8620adea2045024d5189a68d97af6f68161f714f09a712cdd9fc6d06524ea818cf2e1a py3-sphinxcontrib-htmlhelp-1.0.1.tar.gz"