summaryrefslogtreecommitdiff
path: root/user/py3-sphinxcontrib-serializinghtml
diff options
context:
space:
mode:
authorBrandon Bergren <git@bdragon.rtk0.net>2019-04-06 21:58:09 -0500
committerBrandon Bergren <git@bdragon.rtk0.net>2019-04-06 21:59:00 -0500
commit64d7aa8301c599bf348897882e50f2a94d7b60df (patch)
tree8799e43393728de837605821b7133e99086b9a81 /user/py3-sphinxcontrib-serializinghtml
parentf900125406ef285e9234a64575800b6b315c7578 (diff)
downloadpackages-64d7aa8301c599bf348897882e50f2a94d7b60df.tar.gz
packages-64d7aa8301c599bf348897882e50f2a94d7b60df.tar.bz2
packages-64d7aa8301c599bf348897882e50f2a94d7b60df.tar.xz
packages-64d7aa8301c599bf348897882e50f2a94d7b60df.zip
Add py3-sphinx and its dependencies.
This will be needed in the future to build qemu-doc for qemu 4.0.
Diffstat (limited to 'user/py3-sphinxcontrib-serializinghtml')
-rw-r--r--user/py3-sphinxcontrib-serializinghtml/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/user/py3-sphinxcontrib-serializinghtml/APKBUILD b/user/py3-sphinxcontrib-serializinghtml/APKBUILD
new file mode 100644
index 000000000..d576f8de8
--- /dev/null
+++ b/user/py3-sphinxcontrib-serializinghtml/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Brandon Bergren <git@bdragon.rtk0.net>
+# Maintainer: Brandon Bergren <git@bdragon.rtk0.net>
+pkgname=py3-sphinxcontrib-serializinghtml
+_pkgname=sphinxcontrib-serializinghtml
+pkgver=1.1.3
+pkgrel=0
+pkgdesc="A Sphinx extension to output serialized HTML (json and pickle)"
+url="https://pypi.python.org/pypi/sphinxcontrib-serializinghtml"
+arch="noarch"
+options="!check" # Cyclic dependency with sphinx
+license="BSD-2-Clause"
+depends="python3 py3-markupsafe"
+makedepends="python3-dev"
+checkdepends="py3-sphinx py3-pytest"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ PYTHONWARNINGS="all,ignore::DeprecationWarning:docutils.io" pytest --durations 25
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+
+}
+
+sha512sums="984d1760c61886408fe16c717aa1daea6591721928291267d519ea9c6eeab65d8a46d018a7c57aa8508ca408c9e919b7094d2580d30141ce7bacf5a18504cb55 py3-sphinxcontrib-serializinghtml-1.1.3.tar.gz"