summaryrefslogtreecommitdiff
path: root/user/py3-tz/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2018-12-29 21:59:07 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2018-12-29 21:59:07 +0000
commit1d5bbfe40b832dccae70c9c3570e4e165f15d8ad (patch)
treeed952e2b60755e98a21270db253e7e0af6642510 /user/py3-tz/APKBUILD
parentc999dc9826ec3ac419865778b19f4ba2e710a50f (diff)
parente4a73a3d14a57d6ba40fccb850ee3b27a4e9f962 (diff)
downloadpackages-1d5bbfe40b832dccae70c9c3570e4e165f15d8ad.tar.gz
packages-1d5bbfe40b832dccae70c9c3570e4e165f15d8ad.tar.bz2
packages-1d5bbfe40b832dccae70c9c3570e4e165f15d8ad.tar.xz
packages-1d5bbfe40b832dccae70c9c3570e4e165f15d8ad.zip
Merge branch 'add-certbot' into 'master'
Add certbot and dependencies This branch brings Certbot support to Adélie Linux. Tests were supported in packages where it was reasonable, avoiding long dependency chains (AKA rabbit holes). Some highlights: * Effort was made to ensure everything worked with Python 3; * Python 2.x-only libraries were worked around or removed from dependencies where possible; * Packages were made to defer to system files (such as zoneinfo and ca-cert files) where possible; * Packages were added in dependency-stack order; all dependencies for a package should've been added before the higher level package. There are a lot of packages here, so there may be some edge cases that the runtime testing of certbot did not catch. I was able to successfully receive a brand new wildcard + bare domain (SAN) Let's Encrypt certificate and serve a website over the network to a machine running Firefox 63.0.1. **EDIT 2018-11-28:** I've gone through each APKBUILD and addressed the common pitfalls I noticed in addition to the comments already issued. Packages were version-bumped where possible. See merge request !113
Diffstat (limited to 'user/py3-tz/APKBUILD')
-rw-r--r--user/py3-tz/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/user/py3-tz/APKBUILD b/user/py3-tz/APKBUILD
new file mode 100644
index 000000000..6dc33045e
--- /dev/null
+++ b/user/py3-tz/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Peter Bui <pnutzh4x0r@gmail.com>
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: zlg <zlg+adelie@zlg.space>
+pkgname=py3-tz
+_pkgname=pytz
+pkgver=2018.5
+pkgrel=0
+pkgdesc="Timezone definitions for Python"
+url="http://pytz.sourceforge.net/"
+arch="noarch"
+license="MIT"
+options="!check" # flake8, sphinx
+depends="python3 tzdata"
+makedepends="python3-dev unzip"
+subpackages=""
+source="https://pypi.io/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ zoneinfo-noinstall.patch
+ zoneinfo-fix.patch"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="35b6bdd25b8e57c693da4379c2032401ef3cf290a57d8448c67dcaf1491a21d27ff25d932ef3ec3a51e31fbb7541e081073f292867a7d1ad47904b69dc7e4863 pytz-2018.5.tar.gz
+be61b829014be0d0d7db0c544481d378a95324c1f5968cbbcd7887c6ee8ce52a0b47ae734e16fc5fb2429d8d49c8ef199b6b3b7194f9e654699bb73ab8f3a10d zoneinfo-noinstall.patch
+a09467dbb00c1ab9f7e7527d9b020a6d913b8da2380a5359e782f27ccf9ec4dd4f50bfc92c95dc2e793904242c8139793c15e78e651d2777fb3b3abc48fcd640 zoneinfo-fix.patch"