summaryrefslogtreecommitdiff
path: root/user/py3-virtualenv/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2018-04-17 02:41:35 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2018-04-17 02:41:35 +0000
commit43b60beb3683582dba2610095c5c0d9fe103ec4c (patch)
treeee2d0852258898f90b9033fc54161c3f90fd8e7d /user/py3-virtualenv/APKBUILD
parent8e41995ddbb56175eb00995ab0f7f750e5bde2da (diff)
parent4f4582578d04b74931148cf5a3e4cc6653188bc6 (diff)
downloadpackages-43b60beb3683582dba2610095c5c0d9fe103ec4c.tar.gz
packages-43b60beb3683582dba2610095c5c0d9fe103ec4c.tar.bz2
packages-43b60beb3683582dba2610095c5c0d9fe103ec4c.tar.xz
packages-43b60beb3683582dba2610095c5c0d9fe103ec4c.zip
Merge branch 'meta/tox' into 'master'
Basic python3 testing packages ``` Includes: * user/py3-tox * user/py3-setuptools * user/py3-pluggy * user/py3-virtualenv * user/py3-pytest ** user/py3-py Most of these packages use tox itself for tests, so !check until we have a copy of tox on the mirrors with which to bootstrap. ``` See merge request !16
Diffstat (limited to 'user/py3-virtualenv/APKBUILD')
-rw-r--r--user/py3-virtualenv/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/user/py3-virtualenv/APKBUILD b/user/py3-virtualenv/APKBUILD
new file mode 100644
index 000000000..8a4dde3e1
--- /dev/null
+++ b/user/py3-virtualenv/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Max Rees <maxcrees@me.com>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=py3-virtualenv
+_pkgname=virtualenv
+pkgver=15.1.0
+pkgrel=0
+pkgdesc="Virtual Python Environment builder"
+url="https://pypi.python.org/pypi/virtualenv"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="python3-dev"
+checkdepends="py3-pytest py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ test-python3.patch"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+ sed -ie "s/env python$/env python3/" virtualenv.py
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py test
+ cd tests
+ ./test_activate.sh
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="d7e95b8c017ec076210f30b6fd4bb44be2f7dc0257492c25bb00fee597d3ade34226d03539180f1edaf2d27b361f8efdabb92d3476e13785b890878ee1295cb2 py3-virtualenv-15.1.0.tar.gz
+8e022416eb10289fd5215f3810203eefb450ce2fca7bdc581b5cd1892f41f34815beec35fc6c744991536c1f2edebd58ab934a4414c6fe2ae6387aea02787ef8 test-python3.patch"