summaryrefslogtreecommitdiff
path: root/user/py3-virtualenv/test-python3.6.patch
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2018-10-22 21:02:23 -0400
committerMax Rees <maxcrees@me.com>2018-10-22 21:02:23 -0400
commit69acbb3fc1e13b86d6dcbf1b26d895e0340ca7a9 (patch)
tree778a5742f1552c9bf4dc3d796be3b4833fbdb4d1 /user/py3-virtualenv/test-python3.6.patch
parente9c9bbec9cd0f143eeab03b192f3acca6079c18d (diff)
downloadpackages-69acbb3fc1e13b86d6dcbf1b26d895e0340ca7a9.tar.gz
packages-69acbb3fc1e13b86d6dcbf1b26d895e0340ca7a9.tar.bz2
packages-69acbb3fc1e13b86d6dcbf1b26d895e0340ca7a9.tar.xz
packages-69acbb3fc1e13b86d6dcbf1b26d895e0340ca7a9.zip
user/py3-virtualenv: options=net because virtualenvs are stupid
Diffstat (limited to 'user/py3-virtualenv/test-python3.6.patch')
-rw-r--r--user/py3-virtualenv/test-python3.6.patch96
1 files changed, 96 insertions, 0 deletions
diff --git a/user/py3-virtualenv/test-python3.6.patch b/user/py3-virtualenv/test-python3.6.patch
new file mode 100644
index 000000000..782aca2c5
--- /dev/null
+++ b/user/py3-virtualenv/test-python3.6.patch
@@ -0,0 +1,96 @@
+--- virtualenv-15.1.0/tests/test_activate_output.expected 2016-11-16 02:39:30.000000000 +0000
++++ virtualenv-15.1.0/tests/test_activate_output.expected 2018-01-10 23:31:17.840000000 +0000
+@@ -1,2 +1,4 @@
+-New python executable in /tmp/test_virtualenv_activate.venv/bin/python
++Using base prefix '/usr'
++New python executable in /tmp/test_virtualenv_activate.venv/bin/python3
++Also creating executable in /tmp/test_virtualenv_activate.venv/bin/python
+ Installing setuptools, pip, wheel...done.
+--- virtualenv-15.1.0/tests/test_virtualenv.py 2016-11-16 02:39:30.000000000 +0000
++++ virtualenv-15.1.0/tests/test_virtualenv.py 2018-01-11 03:40:22.270000000 +0000
+@@ -58,13 +58,13 @@
+ def test_activate_after_future_statements():
+ """Should insert activation line after last future statement"""
+ script = [
+- '#!/usr/bin/env python',
++ '#!/usr/bin/env python3',
+ 'from __future__ import with_statement',
+ 'from __future__ import print_function',
+ 'print("Hello, world!")'
+ ]
+ assert virtualenv.relative_script(script) == [
+- '#!/usr/bin/env python',
++ '#!/usr/bin/env python3',
+ 'from __future__ import with_statement',
+ 'from __future__ import print_function',
+ '',
+@@ -110,7 +110,7 @@
+ if virtualenv.is_win:
+ required_executables = ['python.exe', 'pythonw.exe']
+ else:
+- py_exe_no_version = 'python'
++ py_exe_no_version = 'python3'
+ py_exe_version_major = 'python%s' % sys.version_info[0]
+ py_exe_version_major_minor = 'python%s.%s' % (
+ sys.version_info[0], sys.version_info[1])
+--- virtualenv-15.1.0/tests/test_activate.sh 2016-11-16 02:39:30.000000000 +0000
++++ virtualenv-15.1.0/tests/test_activate.sh 2018-01-11 03:49:05.070000000 +0000
+@@ -19,7 +19,7 @@
+ echo "$0: Created virtualenv ${TESTENV}." 1>&2
+
+ echo "$0: Activating ${TESTENV}..." 1>&2
+-. ${TESTENV}/bin/activate
++PS1="${PS1:-}" . ${TESTENV}/bin/activate
+ echo "$0: Activated ${TESTENV}." 1>&2
+
+ echo "$0: Checking value of \$VIRTUAL_ENV..." 1>&2
+@@ -31,14 +31,14 @@
+
+ echo "$0: \$VIRTUAL_ENV = \"${VIRTUAL_ENV}\" -- OK." 1>&2
+
+-echo "$0: Checking output of \$(which python)..." 1>&2
++echo "$0: Checking output of \$(which python3)..." 1>&2
+
+-if [ "$(which python)" != "${TESTENV}/bin/python" ]; then
+- echo "$0: Expected \$(which python) to return \"${TESTENV}/bin/python\"; actual value: \"$(which python)\"!" 1>&2
++if [ "$(which python3)" != "${TESTENV}/bin/python3" ]; then
++ echo "$0: Expected \$(which python3) to return \"${TESTENV}/bin/python3\"; actual value: \"$(which python3)\"!" 1>&2
+ exit 3
+ fi
+
+-echo "$0: Output of \$(which python) is OK." 1>&2
++echo "$0: Output of \$(which python3) is OK." 1>&2
+
+ echo "$0: Checking output of \$(which pip)..." 1>&2
+
+@@ -60,7 +60,7 @@
+
+ echo "$0: Executing a simple Python program..." 1>&2
+
+-TESTENV=${TESTENV} python <<__END__
++TESTENV=${TESTENV} python3 <<__END__
+ import os, sys
+
+ expected_site_packages = os.path.join(os.environ['TESTENV'], 'lib','python%s' % sys.version[:3], 'site-packages')
+--- virtualenv-16.0.0/setup.py 2018-05-16 19:36:07.000000000 -0400
++++ virtualenv-16.0.0/setup.py 2018-10-22 20:56:04.691681656 -0400
+@@ -33,7 +33,7 @@ try:
+ },
+ 'zip_safe': False,
+ 'cmdclass': {'test': PyTest},
+- 'tests_require': ['pytest', 'mock'],
++ 'tests_require': ['pytest'],
+ }
+ except ImportError:
+ from distutils.core import setup
+--- virtualenv-16.0.0/tests/test_virtualenv.py 2018-05-16 19:36:07.000000000 -0400
++++ virtualenv-16.0.0/tests/test_virtualenv.py 2018-10-22 20:56:38.771682266 -0400
+@@ -7,7 +7,7 @@ import tempfile
+ import pytest
+ import platform # noqa
+
+-from mock import patch, Mock
++from unittest.mock import patch, Mock
+
+
+ def test_version():