summaryrefslogtreecommitdiff
path: root/user/py3-virtualenv
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2018-10-22 21:02:23 -0400
committerMax Rees <maxcrees@me.com>2018-10-22 21:02:23 -0400
commit69acbb3fc1e13b86d6dcbf1b26d895e0340ca7a9 (patch)
tree778a5742f1552c9bf4dc3d796be3b4833fbdb4d1 /user/py3-virtualenv
parente9c9bbec9cd0f143eeab03b192f3acca6079c18d (diff)
downloadpackages-69acbb3fc1e13b86d6dcbf1b26d895e0340ca7a9.tar.gz
packages-69acbb3fc1e13b86d6dcbf1b26d895e0340ca7a9.tar.bz2
packages-69acbb3fc1e13b86d6dcbf1b26d895e0340ca7a9.tar.xz
packages-69acbb3fc1e13b86d6dcbf1b26d895e0340ca7a9.zip
user/py3-virtualenv: options=net because virtualenvs are stupid
Diffstat (limited to 'user/py3-virtualenv')
-rw-r--r--user/py3-virtualenv/APKBUILD7
-rw-r--r--user/py3-virtualenv/test-python3.6.patch (renamed from user/py3-virtualenv/test-python3.patch)22
2 files changed, 26 insertions, 3 deletions
diff --git a/user/py3-virtualenv/APKBUILD b/user/py3-virtualenv/APKBUILD
index 3b699448c..d78f6e7e7 100644
--- a/user/py3-virtualenv/APKBUILD
+++ b/user/py3-virtualenv/APKBUILD
@@ -7,12 +7,13 @@ pkgrel=0
pkgdesc="Virtual Python Environment builder"
url="https://pypi.org/project/virtualenv"
arch="noarch"
+options="net"
license="MIT"
depends="python3"
makedepends="python3-dev"
checkdepends="py3-pytest cmd:which"
-source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
- test-python3.patch"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/v/$_pkgname/$_pkgname-$pkgver.tar.gz
+ test-python3.6.patch"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
@@ -34,4 +35,4 @@ package() {
}
sha512sums="43bc37f1da1b65e9a2df5a8813a801f27f5783b7211219d441d1c2132789917df42fdc0aba1d5ec51e3d6f7583af9474d59c1f532d8880c8c325ccc96e73b3df py3-virtualenv-16.0.0.tar.gz
-8e022416eb10289fd5215f3810203eefb450ce2fca7bdc581b5cd1892f41f34815beec35fc6c744991536c1f2edebd58ab934a4414c6fe2ae6387aea02787ef8 test-python3.patch"
+9c68dcda515dfc974433c9a68d81be0b028a7967eebb1b6d1d912c3859c7925fe970f1668ac9e406768de91ed32b27b3b8ea7a4939f8adc7a09e1bf904df10b9 test-python3.6.patch"
diff --git a/user/py3-virtualenv/test-python3.patch b/user/py3-virtualenv/test-python3.6.patch
index 8b4a99b51..782aca2c5 100644
--- a/user/py3-virtualenv/test-python3.patch
+++ b/user/py3-virtualenv/test-python3.6.patch
@@ -72,3 +72,25 @@
import os, sys
expected_site_packages = os.path.join(os.environ['TESTENV'], 'lib','python%s' % sys.version[:3], 'site-packages')
+--- virtualenv-16.0.0/setup.py 2018-05-16 19:36:07.000000000 -0400
++++ virtualenv-16.0.0/setup.py 2018-10-22 20:56:04.691681656 -0400
+@@ -33,7 +33,7 @@ try:
+ },
+ 'zip_safe': False,
+ 'cmdclass': {'test': PyTest},
+- 'tests_require': ['pytest', 'mock'],
++ 'tests_require': ['pytest'],
+ }
+ except ImportError:
+ from distutils.core import setup
+--- virtualenv-16.0.0/tests/test_virtualenv.py 2018-05-16 19:36:07.000000000 -0400
++++ virtualenv-16.0.0/tests/test_virtualenv.py 2018-10-22 20:56:38.771682266 -0400
+@@ -7,7 +7,7 @@ import tempfile
+ import pytest
+ import platform # noqa
+
+-from mock import patch, Mock
++from unittest.mock import patch, Mock
+
+
+ def test_version():