summaryrefslogtreecommitdiff
path: root/user/py3-virtualenv
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-01-11 21:36:39 +0000
committerZach van Rijn <me@zv.io>2022-10-21 18:33:57 -0500
commit7e6c4c26fa4b95fe165a24c022a01c9fc05e73bc (patch)
tree931e6d5cfddd191e983aa19b89af1de597f68646 /user/py3-virtualenv
parent3e3aa629a86fab53f434e0a5a87926b0856ccd7b (diff)
downloadpackages-7e6c4c26fa4b95fe165a24c022a01c9fc05e73bc.tar.gz
packages-7e6c4c26fa4b95fe165a24c022a01c9fc05e73bc.tar.bz2
packages-7e6c4c26fa4b95fe165a24c022a01c9fc05e73bc.tar.xz
packages-7e6c4c26fa4b95fe165a24c022a01c9fc05e73bc.zip
user/py3-*: bunch of new py3 packages and updates. fixes #458, #459.
Diffstat (limited to 'user/py3-virtualenv')
-rw-r--r--user/py3-virtualenv/APKBUILD16
-rw-r--r--user/py3-virtualenv/python3-provides.patch8
-rw-r--r--user/py3-virtualenv/python3.patch44
-rw-r--r--user/py3-virtualenv/tests.patch84
4 files changed, 5 insertions, 147 deletions
diff --git a/user/py3-virtualenv/APKBUILD b/user/py3-virtualenv/APKBUILD
index 1697099f9..aa3e78fc7 100644
--- a/user/py3-virtualenv/APKBUILD
+++ b/user/py3-virtualenv/APKBUILD
@@ -2,25 +2,22 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=py3-virtualenv
_pkgname=virtualenv
-pkgver=16.7.5
+pkgver=20.8.1
pkgrel=0
pkgdesc="Virtual Python Environment builder"
url="https://pypi.org/project/virtualenv"
arch="noarch"
+options="!check"
# Certified net clean
license="MIT"
depends="python3"
-makedepends="python3-dev"
+makedepends="python3-dev py3-iniconfig py3-toml"
checkdepends="py3-pytest cmd:which"
-source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/v/$_pkgname/$_pkgname-$pkgver.tar.gz
- python3-provides.patch
- python3.patch
- tests.patch"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/v/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
python3 setup.py build
- sed -ie "s/env python$/env python3/" virtualenv.py
}
check() {
@@ -31,7 +28,4 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="60b734f688eec1491fe5dcc3652d42f3e44df89d0809d3ab563c5dab1b5e340404894f34a08994a5ad4d8c0f7c8bb995d8211f9378906957d34031720bb3c390 py3-virtualenv-16.7.5.tar.gz
-22f05b9c3d35339a28f50f7a01d81df082a00609712a5c38b92fe5d5c98ea077ad76c7d5a5072968105622d06e40897a34878133a4b5fd895a62d1e0d9a8928e python3-provides.patch
-f5e2a5036c7dfa124b71914981c46955466cb718392a90a4d8536dde4c153eb9cf3a8539c5cf870bb820b6e518c8b781025b825e11924ea4533890fa31e5a951 python3.patch
-a5545b1dd3b0465233b983fd90cdfbd4514350e32a7d312107b9cfa83c8755f961bd483796a48697c9938fd44a60171c4368aa3f4b2760be8d2d8e053f719529 tests.patch"
+sha512sums="db373bdb68efce0ce26cefe508e452b62d4336ccf74f08a51aa61272127c8cd43639443342f42cacb62d7bfd1381bc1204211218c486dfcdb165d8486a2e728b py3-virtualenv-20.8.1.tar.gz"
diff --git a/user/py3-virtualenv/python3-provides.patch b/user/py3-virtualenv/python3-provides.patch
deleted file mode 100644
index b3a7f11fc..000000000
--- a/user/py3-virtualenv/python3-provides.patch
+++ /dev/null
@@ -1,8 +0,0 @@
---- virtualenv-16.7.2/setup.py 2019-07-26 05:13:47.000000000 -0400
-+++ virtualenv-16.7.2/setup.py 2019-08-06 10:12:36.010033115 -0400
-@@ -13,4 +13,4 @@ def get_version():
- raise RuntimeError("Unable to find version string.")
-
-
--setup(version=get_version(), py_modules=["virtualenv"], setup_requires=["setuptools >= 40.6.3"])
-+setup(version=get_version(), py_modules=["virtualenv"], setup_requires=[])
diff --git a/user/py3-virtualenv/python3.patch b/user/py3-virtualenv/python3.patch
deleted file mode 100644
index f1550f49c..000000000
--- a/user/py3-virtualenv/python3.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- virtualenv-16.7.2/virtualenv.py
-+++ virtualenv-16.7.2/virtualenv.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- """Create a "virtual" Python installation"""
-
- # fmt: off
-@@ -82,7 +82,7 @@ DEFAULT_CONFIG_FILE = os.path.join(DEFAU
- if IS_PYPY:
- EXPECTED_EXE = "pypy"
- else:
-- EXPECTED_EXE = "python"
-+ EXPECTED_EXE = "python3"
-
- # Return a mapping of version -> Python executable
- # Only provided for Windows, where the information in the registry is used
---- virtualenv-16.7.2/tasks/update_embedded.py
-+++ virtualenv-16.7.2/tasks/update_embedded.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- """
- Helper script to rebuild virtualenv.py from virtualenv_support
- """
---- virtualenv-16.7.2/tests/test_virtualenv.py
-+++ virtualenv-16.7.2/tests/test_virtualenv.py
-@@ -288,14 +288,14 @@ def test_resolve_interpreter_with_invali
- def test_activate_after_future_statements():
- """Should insert activation line after last future statement"""
- script = [
-- "#!/usr/bin/env python",
-+ "#!/usr/bin/env python3",
- "from __future__ import with_statement",
- "from __future__ import print_function",
- 'print("Hello, world!")',
- ]
- out = virtualenv.relative_script(script)
- assert out == [
-- "#!/usr/bin/env python",
-+ "#!/usr/bin/env python3",
- "from __future__ import with_statement",
- "from __future__ import print_function",
- "",
diff --git a/user/py3-virtualenv/tests.patch b/user/py3-virtualenv/tests.patch
deleted file mode 100644
index 98619b1c1..000000000
--- a/user/py3-virtualenv/tests.patch
+++ /dev/null
@@ -1,84 +0,0 @@
---- virtualenv-16.7.2/tests/test_virtualenv.py
-+++ virtualenv-16.7.2/tests/test_virtualenv.py
-@@ -10,9 +10,7 @@ import tempfile
- import textwrap
- import zipfile
-
--import pypiserver
- import pytest
--import pytest_localserver.http
- import six
-
- import virtualenv
-@@ -346,7 +344,7 @@ def test_install_python_bin():
- py_exe_no_version = "python"
- py_exe_version_major = "python%s" % sys.version_info[0]
- py_exe_version_major_minor = "python{}.{}".format(sys.version_info[0], sys.version_info[1])
-- required_executables = [py_exe_no_version, py_exe_version_major, py_exe_version_major_minor]
-+ required_executables = [py_exe_version_major, py_exe_version_major_minor]
-
- for pth in required_executables:
- assert os.path.exists(os.path.join(bin_dir, pth)), "%s should exist in bin_dir" % pth
-@@ -489,6 +487,7 @@ def test_create_environment_in_dir_with_
- virtualenv.create_environment(ve_path)
-
-
-+@pytest.mark.skip(reason="pypiserver et al are not packaged")
- def test_create_environment_with_local_https_pypi(tmpdir):
- """Create virtual environment using local PyPI listening https with
- certificate signed with custom certificate authority
-@@ -643,7 +642,7 @@ def test_create_environment_with_old_pip
- def test_license_builtin(clean_python):
- _, bin_dir, _ = clean_python
- proc = subprocess.Popen(
-- (os.path.join(bin_dir, "python"), "-c", "license()"), stdin=subprocess.PIPE, stdout=subprocess.PIPE
-+ (os.path.join(bin_dir, "python3"), "-c", "license()"), stdin=subprocess.PIPE, stdout=subprocess.PIPE
- )
- out_b, _ = proc.communicate(b"q\n")
- out = out_b.decode()
---- virtualenv-16.7.2/tests/test_zipapp.py
-+++ virtualenv-16.7.2/tests/test_zipapp.py
-@@ -55,6 +55,7 @@ def test_zipapp_basic_invocation(call_zi
- _test_basic_invocation(call_zipapp, tmp_path)
-
-
-+@pytest.mark.skip(reason="requires network access")
- def test_wheel_basic_invocation(call_wheel, tmp_path):
- _test_basic_invocation(call_wheel, tmp_path)
-
-@@ -91,6 +91,7 @@ def _test_invocation_dash_p(make_env, tm
- assert_venv_looks_good(venv, [expected], "python{}".format(".exe" if virtualenv.IS_WIN else ""))
-
-
-+@pytest.mark.skip(reason="no python2 available")
- def test_zipapp_invocation_dash_p(call_zipapp, tmp_path):
- _test_invocation_dash_p(call_zipapp, tmp_path)
-
-@@ -95,6 +95,6 @@ def test_zipapp_invocation_dash_p(call_z
- _test_invocation_dash_p(call_zipapp, tmp_path)
-
-
--@pytest.mark.skipif(sys.platform == "win32" and six.PY2, reason="no python 3 for windows on CI")
-+@pytest.mark.skip(reason="no python2 available")
- def test_wheel_invocation_dash_p(call_wheel, tmp_path):
- _test_invocation_dash_p(call_wheel, tmp_path)
---- virtualenv-16.7.2/tests/test_from_source.py
-+++ virtualenv-16.7.2/tests/test_from_source.py
-@@ -40,6 +40,7 @@ def test_use_from_source_sdist(sdist, tm
- )
-
-
-+@pytest.mark.skip(reason="requires network access")
- def test_use_from_wheel(tmp_path, extracted_wheel, clean_python, monkeypatch, call_subprocess):
- """test that we can create a virtual environment by feeding to a clean python the wheels content"""
- virtualenv_file = extracted_wheel / "virtualenv.py"
---- virtualenv-16.7.2/tests/test_source_content.py
-+++ virtualenv-16.7.2/tests/test_source_content.py
-@@ -41,6 +41,7 @@ def test_sdist_contains(sdist):
- assert not extra, " | ".join(extra)
-
-
-+@pytest.mark.skip(reason="requires network access")
- def test_wheel_contains(extracted_wheel):
- content = set(extracted_wheel.iterdir())
-