summaryrefslogtreecommitdiff
path: root/user/py3-zipp
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2019-08-08 03:31:00 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2019-08-08 03:31:00 +0000
commita01cc01896f6fb3b472622711d632100b3c86cdb (patch)
tree21fb15bbd40fabb290446ee3aa09e491306f2a87 /user/py3-zipp
parent5c572c8c2013c5833d041ea4411a189d85f312fa (diff)
parent3f98aef31c277c4f673d3ad9db6b11b6e973ea5e (diff)
downloadpackages-a01cc01896f6fb3b472622711d632100b3c86cdb.tar.gz
packages-a01cc01896f6fb3b472622711d632100b3c86cdb.tar.bz2
packages-a01cc01896f6fb3b472622711d632100b3c86cdb.tar.xz
packages-a01cc01896f6fb3b472622711d632100b3c86cdb.zip
Merge branch 'sr.2019.08.06' into 'master'
Misc package bumps for Maintainer: Max Rees, 2019.08.06 See merge request adelie/packages!313
Diffstat (limited to 'user/py3-zipp')
-rw-r--r--user/py3-zipp/APKBUILD34
-rw-r--r--user/py3-zipp/scm.patch19
2 files changed, 53 insertions, 0 deletions
diff --git a/user/py3-zipp/APKBUILD b/user/py3-zipp/APKBUILD
new file mode 100644
index 000000000..ba2673027
--- /dev/null
+++ b/user/py3-zipp/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Max Rees <maxcrees@me.com>
+# Maintainer: Max Rees <maxcrees@me.com>
+# FIXME: drop after python3 >= 3.8.0
+pkgname=py3-zipp
+_pkgname=zipp
+_p="${_pkgname#?}"
+_p="${_pkgname%"$_p"}"
+pkgver=0.5.2
+pkgrel=0
+pkgdesc="Backport of Python 3.7's zip.Path"
+url="https://pypi.python.org/pypi/zipp"
+arch="noarch"
+# Certified net clean
+license="MIT"
+depends="python3"
+makedepends=""
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz
+ scm.patch"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="8c84b620844315ab1f1aa3c5bb29dcdf1271a0139198b5c3d6aa31ecb9a86f0dcef963819403d971ae0461c737312c064572c57ecf32d73dc973a5f69cf0375c py3-zipp-0.5.2.tar.gz
+7e9061e3ba0e3ded95633f1baa1438f7bb7ea32cecd423001bcbafdfad93aca5bfe0a444035e41b31aeea66b31c86b22854b4f18b2cbbfda356986a2433ca677 scm.patch"
diff --git a/user/py3-zipp/scm.patch b/user/py3-zipp/scm.patch
new file mode 100644
index 000000000..b7d0f690e
--- /dev/null
+++ b/user/py3-zipp/scm.patch
@@ -0,0 +1,19 @@
+--- zipp-0.5.2/setup.cfg 2019-07-07 17:14:00.000000000 -0400
++++ zipp-0.5.2/setup.cfg 2019-08-06 05:03:34.500180967 -0400
+@@ -22,7 +22,7 @@ packages = find:
+ include_package_data = true
+ python_requires = >=2.7
+ install_requires =
+-setup_requires = setuptools_scm >= 1.15.0
++setup_requires =
+
+ [options.extras_require]
+ testing =
+--- zipp-0.5.2/setup.py 2019-07-07 17:13:42.000000000 -0400
++++ zipp-0.5.2/setup.py 2019-08-06 05:03:01.970180844 -0400
+@@ -3,4 +3,4 @@
+ import setuptools
+
+ if __name__ == "__main__":
+- setuptools.setup(use_scm_version=True)
++ setuptools.setup(version='0.5.2')