summaryrefslogtreecommitdiff
path: root/user/py3-zope-hookable/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2019-01-04 01:58:51 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2019-01-04 01:58:51 +0000
commit8a2b1ad85893e7b4ccf11b90953e175ea4bb7c9c (patch)
treefeca5626a9f6711fd9ba5a95dcf32c1600c98ead /user/py3-zope-hookable/APKBUILD
parent23931e68295808b529cab095c98f0055991aa44b (diff)
parent5290d9c4a693d4b69d99fed7bc30e82279c620b4 (diff)
downloadpackages-8a2b1ad85893e7b4ccf11b90953e175ea4bb7c9c.tar.gz
packages-8a2b1ad85893e7b4ccf11b90953e175ea4bb7c9c.tar.bz2
packages-8a2b1ad85893e7b4ccf11b90953e175ea4bb7c9c.tar.xz
packages-8a2b1ad85893e7b4ccf11b90953e175ea4bb7c9c.zip
Merge branch 'fix-zope-component' into 'master'
Fix py3-zope-component dependencies This branch adds missing `py3-zope-component` dependencies that `certbot` v0.30.0 depends on. This branch should be merged before !132 due to these missing deps. EDIT: The descriptions aren't as good as I'd like, so any guidance or suggestions in that department are appreciated. See merge request !133
Diffstat (limited to 'user/py3-zope-hookable/APKBUILD')
-rw-r--r--user/py3-zope-hookable/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/user/py3-zope-hookable/APKBUILD b/user/py3-zope-hookable/APKBUILD
new file mode 100644
index 000000000..a2b4493be
--- /dev/null
+++ b/user/py3-zope-hookable/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: zlg <zlg+adelie@zlg.space>
+# Maintainer: zlg <zlg+adelie@zlg.space>
+pkgname=py3-zope-hookable
+_pkgname=zope.hookable
+pkgver=4.2.0
+pkgrel=0
+pkgdesc="A library that provides an interface for hookable functions"
+url="https://github.com/zopefoundation/zope.hookable"
+arch="all"
+options="!check" # needs zope.testing
+license="ZPL-2.1"
+depends="python3"
+makedepends="python3-dev py3-tox coverage"
+subpackages=""
+source="$_pkgname-$pkgver.tar.gz::https://github.com/zopefoundation/$_pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="aeeafff7e5c7cbe3d5944864278896f926086514e75be1d5956e32fc0a3769ac11b008c3855a0816084c7deb64f14c65db49852dac2beaf06420a304af6ebb69 zope.hookable-4.2.0.tar.gz"