summaryrefslogtreecommitdiff
path: root/user/qml-box2d
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-03-25 15:53:31 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-03-25 15:53:31 -0500
commit5504778e202f1a03e6a0daa09de9020b4b6eacc9 (patch)
tree0478f07572038fef871ab6c0fdbe61a1d30ff51c /user/qml-box2d
parent46d6c75f081981fbeef723f92842b23e3d0c9d26 (diff)
downloadpackages-5504778e202f1a03e6a0daa09de9020b4b6eacc9.tar.gz
packages-5504778e202f1a03e6a0daa09de9020b4b6eacc9.tar.bz2
packages-5504778e202f1a03e6a0daa09de9020b4b6eacc9.tar.xz
packages-5504778e202f1a03e6a0daa09de9020b4b6eacc9.zip
user/qml-box2d: new package
Diffstat (limited to 'user/qml-box2d')
-rw-r--r--user/qml-box2d/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/user/qml-box2d/APKBUILD b/user/qml-box2d/APKBUILD
new file mode 100644
index 000000000..1d06627cd
--- /dev/null
+++ b/user/qml-box2d/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=qml-box2d
+pkgver=0.1.0_pre20180109
+_hash=21e57f1c0fbf6e65072c269f89d98a94ed5d7f7f
+pkgrel=0
+pkgdesc="Physics plugin for QML"
+url="https://github.com/qml-box2d/qml-box2d"
+arch="all"
+options="!check" # All tests are interactive.
+license="Zlib"
+depends=""
+makedepends="qt5-qtbase-dev qt5-qtdeclarative-dev"
+install=""
+subpackages=""
+source="qml-box2d-$pkgver.tar.gz::https://github.com/qml-box2d/qml-box2d/archive/$_hash.tar.gz"
+builddir="$srcdir/qml-box2d-$_hash"
+
+build() {
+ cd "$builddir"
+ qmake-qt5
+ make
+}
+
+package() {
+ cd "$builddir"
+ make install INSTALL_ROOT="$pkgdir"
+}
+
+sha512sums="89a60ef138bd2790d17e1213dcdd611a8a3e763f4a0a35cdae565385868ce6957f0114c538d19f0e50fc87b660611cd65d38b8aa563f344fd5741a65eb5fed70 qml-box2d-0.1.0_pre20180109.tar.gz"