summaryrefslogtreecommitdiff
path: root/user/qpdf
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-23 17:49:13 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-23 17:49:13 -0500
commit38f7e3d4dd2b813c2984be3d71883d6c37f5edb3 (patch)
treef6e23ee95a081b2fd2597fb4fbe30e30d0258408 /user/qpdf
parent8724bd068cdde6fc4f2091caa60e7d63cc3a139d (diff)
downloadpackages-38f7e3d4dd2b813c2984be3d71883d6c37f5edb3.tar.gz
packages-38f7e3d4dd2b813c2984be3d71883d6c37f5edb3.tar.bz2
packages-38f7e3d4dd2b813c2984be3d71883d6c37f5edb3.tar.xz
packages-38f7e3d4dd2b813c2984be3d71883d6c37f5edb3.zip
user/qpdf: pull in, bump to 8.1.0, fix license, modernise
Diffstat (limited to 'user/qpdf')
-rw-r--r--user/qpdf/APKBUILD63
1 files changed, 63 insertions, 0 deletions
diff --git a/user/qpdf/APKBUILD b/user/qpdf/APKBUILD
new file mode 100644
index 000000000..57ff6bcff
--- /dev/null
+++ b/user/qpdf/APKBUILD
@@ -0,0 +1,63 @@
+# Maintainer:
+pkgname=qpdf
+pkgver=8.1.0
+pkgrel=0
+pkgdesc="Command-line tools and library for transforming PDF files"
+url="http://qpdf.sourceforge.net"
+arch="all"
+license="Apache-2.0 OR Artistic-2.0"
+depends=""
+makedepends="bash libjpeg-turbo-dev zlib-dev"
+checkdepends="coreutils perl"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs
+ $pkgname-fix-qdf:fix_qdf:noarch"
+source="https://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+
+# secfixes:
+# 7.0.0-r0:
+# - CVE-2017-9208
+# - CVE-2017-9209
+# - CVE-2017-9210
+# - CVE-2017-11624
+# - CVE-2017-11625
+# - CVE-2017-11626
+# - CVE-2017-11627
+# - CVE-2017-12595
+
+prepare() {
+ update_config_sub
+ default_prepare
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-static
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+fix_qdf() {
+ depends="qpdf perl"
+ pkgdesc="Repair PDF files in QDF form after editing"
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/fix-qdf "$subpkgdir"/usr/bin/
+}
+
+sha512sums="1831bcaaed87dae268db5d61805d1483ec5c101f6ce594be660664c119597ae67cf011c2b50092964d785a814d5f6c780935127a89401fe37a1026ae4d3af15c qpdf-8.1.0.tar.gz"