summaryrefslogtreecommitdiff
path: root/user/qt5-qtquickcontrols
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-09 20:27:58 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-09 20:27:58 -0500
commit8145125d52aad4142ca19d07b6b3e65fbd5d4972 (patch)
treed979d3c767f9395bf5c95d43b8015c50aca594e0 /user/qt5-qtquickcontrols
parent56a9ffca1ebbf73c60f015f05cdbbcdbcac4e1ce (diff)
downloadpackages-8145125d52aad4142ca19d07b6b3e65fbd5d4972.tar.gz
packages-8145125d52aad4142ca19d07b6b3e65fbd5d4972.tar.bz2
packages-8145125d52aad4142ca19d07b6b3e65fbd5d4972.tar.xz
packages-8145125d52aad4142ca19d07b6b3e65fbd5d4972.zip
user/qt5-qtquickcontrols: new package
Diffstat (limited to 'user/qt5-qtquickcontrols')
-rw-r--r--user/qt5-qtquickcontrols/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/user/qt5-qtquickcontrols/APKBUILD b/user/qt5-qtquickcontrols/APKBUILD
new file mode 100644
index 000000000..63c9e8690
--- /dev/null
+++ b/user/qt5-qtquickcontrols/APKBUILD
@@ -0,0 +1,30 @@
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=qt5-qtquickcontrols
+_pkgname=qtquickcontrols-opensource-src
+pkgver=5.9.6
+pkgrel=0
+pkgdesc="Qt 5 - controls for use with Qt Quick"
+url="https://qt.io"
+arch="all"
+license="(LGPL-2.0 with exceptions OR GPL-3.0 with exceptions) AND GFDL-1.3"
+makedepends="qt5-qtbase-dev qt5-qtdeclarative-dev"
+source="https://download.qt.io/official_releases/qt/${pkgver%.*}/$pkgver/submodules/$_pkgname-$pkgver.tar.xz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ qmake
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make install INSTALL_ROOT="$pkgdir"
+}
+
+sha512sums="1a48ede02a0a0ddca6475ec952684045638a61a0db9f545b8ad8b2115f93f3a5586655a24138545d168196a3990f2c6dbef18530af546c60026e1eac91ca832e qtquickcontrols-opensource-src-5.9.6.tar.xz"