summaryrefslogtreecommitdiff
path: root/user/qt5-qtscript/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-27 04:02:42 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-27 04:02:42 -0600
commit47d18b13213ccd7c51894796760f97571c3eb424 (patch)
tree6e31cc5d066c199564a5c8f34a40d313a08c44aa /user/qt5-qtscript/APKBUILD
parent9b07de55dfe6d50baeda3a8feda7f9fcade9c647 (diff)
downloadpackages-47d18b13213ccd7c51894796760f97571c3eb424.tar.gz
packages-47d18b13213ccd7c51894796760f97571c3eb424.tar.bz2
packages-47d18b13213ccd7c51894796760f97571c3eb424.tar.xz
packages-47d18b13213ccd7c51894796760f97571c3eb424.zip
user/qt5: Bump to 5.12.6 LTS
This updates Qt 5 to the latest LTS release available. Notable changes: * The infamous clipboard bug (upstream QTBUG-65145; Gerrit 254187) is fixed! * Qt Declarative's "V4 JIT" is disabled globally on pmmx. It is no longer (easily) possible to turn off the JIT selectively based on CPU capability. * Qt Script builds correctly on GCC 8 now. This does not include: * Build testing of Qt Multimedia (yet); this depends on the time64-isation of the alsa-lib package (at least). * Build testing of Qt Speech (yet); speech-dispatcher also deps on alsa-lib indirectly. * Qt WebKit 5.212. This will be committed later.
Diffstat (limited to 'user/qt5-qtscript/APKBUILD')
-rw-r--r--user/qt5-qtscript/APKBUILD23
1 files changed, 9 insertions, 14 deletions
diff --git a/user/qt5-qtscript/APKBUILD b/user/qt5-qtscript/APKBUILD
index 4f56a9e7d..1b22dbc9c 100644
--- a/user/qt5-qtscript/APKBUILD
+++ b/user/qt5-qtscript/APKBUILD
@@ -1,34 +1,29 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=qt5-qtscript
-_pkgname=qtscript-opensource-src
-pkgver=5.9.7
-pkgrel=1
-pkgdesc="Qt 5 - Deprecated scripting framework for Qt applications"
+_pkgname=qtscript-everywhere-src
+pkgver=5.12.6
+pkgrel=0
+pkgdesc="Deprecated scripting framework for Qt applications"
url="https://www.qt.io/"
arch="all"
-license="LGPL-2.0 with exceptions OR GPL-3.0 with exceptions"
+license="LGPL-3.0-only WITH Qt-LGPL-exception-1.1 OR GPL-3.0-only WITH Qt-GPL-exception-1.0"
+depends=""
makedepends="qt5-qtbase-dev"
subpackages="$pkgname-dev"
-source="https://download.qt.io/official_releases/qt/${pkgver%.*}/$pkgver/submodules/$_pkgname-$pkgver.tar.xz
- gcc8.patch
- "
+source="https://download.qt.io/official_releases/qt/${pkgver%.*}/$pkgver/submodules/$_pkgname-$pkgver.tar.xz"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$builddir"
qmake
- make
+ make 2>build.log
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make INSTALL_ROOT="$pkgdir" install
}
-sha512sums="e019d2e7aa29e1183636503822db960d97f1787fa7517f286acbe42645f2c5daa099cc251ac6640e3243dedb4ef64e509f2e22bca798a7e583063e0ac7635662 qtscript-opensource-src-5.9.7.tar.xz
-426174235ab57b14edf58166327372ba215dfce092b9d4cc07686b326c999d4d6348460a75343791de96b6ad7352c393b4a748d0592865e0d78dc119c12657f2 gcc8.patch"
+sha512sums="31fdcd008c68ab1b17d0a648441e97bba2186a93c8f0e13381e655125a1b1c282682f9db24428c4bb84b28ab5da0dfd7cbea63d326855580a206d81387a2fcc8 qtscript-everywhere-src-5.12.6.tar.xz"