summaryrefslogtreecommitdiff
path: root/user/rust/0005-Remove-nostdlib-and-musl_root-from-musl-targets.patch
diff options
context:
space:
mode:
authorSamuel Holland <samuel@sholland.org>2019-05-26 15:21:24 -0500
committerSamuel Holland <samuel@sholland.org>2019-05-29 04:38:48 +0000
commitd726062dd22ef3eaafd366821fb7c9dde338f060 (patch)
treee443eb75a9559da3b883f3c8d34a3068e46992bb /user/rust/0005-Remove-nostdlib-and-musl_root-from-musl-targets.patch
parent0ee2191bdaf224bcc5c9bd4cfd3e42e0fe5fed16 (diff)
downloadpackages-d726062dd22ef3eaafd366821fb7c9dde338f060.tar.gz
packages-d726062dd22ef3eaafd366821fb7c9dde338f060.tar.bz2
packages-d726062dd22ef3eaafd366821fb7c9dde338f060.tar.xz
packages-d726062dd22ef3eaafd366821fb7c9dde338f060.zip
user/rust: Bump to 1.34.2
Signed-off-by: Samuel Holland <samuel@sholland.org>
Diffstat (limited to 'user/rust/0005-Remove-nostdlib-and-musl_root-from-musl-targets.patch')
-rw-r--r--user/rust/0005-Remove-nostdlib-and-musl_root-from-musl-targets.patch66
1 files changed, 33 insertions, 33 deletions
diff --git a/user/rust/0005-Remove-nostdlib-and-musl_root-from-musl-targets.patch b/user/rust/0005-Remove-nostdlib-and-musl_root-from-musl-targets.patch
index 6053de26b..b8ca29376 100644
--- a/user/rust/0005-Remove-nostdlib-and-musl_root-from-musl-targets.patch
+++ b/user/rust/0005-Remove-nostdlib-and-musl_root-from-musl-targets.patch
@@ -1,4 +1,4 @@
-From 5d98731bae319172c5fbfd8235f62bb00acb3a7d Mon Sep 17 00:00:00 2001
+From d84f9863017bd4bb38c5a2063c679dc3132ecf28 Mon Sep 17 00:00:00 2001
From: Samuel Holland <samuel@sholland.org>
Date: Fri, 8 Sep 2017 22:11:14 -0500
Subject: [PATCH 05/14] Remove -nostdlib and musl_root from musl targets
@@ -19,10 +19,10 @@ Subject: [PATCH 05/14] Remove -nostdlib and musl_root from musl targets
12 files changed, 3 insertions(+), 154 deletions(-)
diff --git a/config.toml.example b/config.toml.example
-index 23943d34b7..5eace54c6b 100644
+index f45db37c33..50692bf74a 100644
--- a/config.toml.example
+++ b/config.toml.example
-@@ -461,12 +461,6 @@
+@@ -470,12 +470,6 @@
# only use static libraries. If unset, the target's default linkage is used.
#crt-static = false
@@ -36,18 +36,18 @@ index 23943d34b7..5eace54c6b 100644
# probably don't want to use this.
#qemu-rootfs = "..."
diff --git a/src/bootstrap/bin/rustc.rs b/src/bootstrap/bin/rustc.rs
-index a0c75cd9e9..f8daab9bd1 100644
+index b6afe317a0..0eace41a5a 100644
--- a/src/bootstrap/bin/rustc.rs
+++ b/src/bootstrap/bin/rustc.rs
-@@ -20,7 +20,6 @@
- extern crate bootstrap;
+@@ -18,7 +18,6 @@
+ #![deny(warnings)]
use std::env;
-use std::ffi::OsString;
use std::io;
use std::path::PathBuf;
use std::process::Command;
-@@ -116,17 +115,6 @@ fn main() {
+@@ -114,17 +113,6 @@ fn main() {
cmd.arg("-Cprefer-dynamic");
}
@@ -66,10 +66,10 @@ index a0c75cd9e9..f8daab9bd1 100644
if let Ok(target_linker) = env::var("RUSTC_TARGET_LINKER") {
cmd.arg(format!("-Clinker={}", target_linker));
diff --git a/src/bootstrap/cc_detect.rs b/src/bootstrap/cc_detect.rs
-index 37844759c7..fa553c0b06 100644
+index dfc243b705..848d1d4b2b 100644
--- a/src/bootstrap/cc_detect.rs
+++ b/src/bootstrap/cc_detect.rs
-@@ -85,7 +85,7 @@ pub fn find(build: &mut Build) {
+@@ -84,7 +84,7 @@ pub fn find(build: &mut Build) {
if let Some(cc) = config.and_then(|c| c.cc.as_ref()) {
cfg.compiler(cc);
} else {
@@ -78,7 +78,7 @@ index 37844759c7..fa553c0b06 100644
}
let compiler = cfg.get_compiler();
-@@ -114,7 +114,7 @@ pub fn find(build: &mut Build) {
+@@ -113,7 +113,7 @@ pub fn find(build: &mut Build) {
if let Some(cxx) = config.and_then(|c| c.cxx.as_ref()) {
cfg.compiler(cxx);
} else {
@@ -87,7 +87,7 @@ index 37844759c7..fa553c0b06 100644
}
let compiler = cfg.get_compiler();
build.verbose(&format!("CXX_{} = {:?}", host, compiler.path()));
-@@ -125,8 +125,7 @@ pub fn find(build: &mut Build) {
+@@ -124,8 +124,7 @@ pub fn find(build: &mut Build) {
fn set_compiler(cfg: &mut cc::Build,
compiler: Language,
target: Interned<String>,
@@ -97,7 +97,7 @@ index 37844759c7..fa553c0b06 100644
match &*target {
// When compiling for android we may have the NDK configured in the
// config.toml in which case we look there. Otherwise the default
-@@ -166,26 +165,6 @@ fn set_compiler(cfg: &mut cc::Build,
+@@ -165,26 +164,6 @@ fn set_compiler(cfg: &mut cc::Build,
}
}
@@ -125,11 +125,11 @@ index 37844759c7..fa553c0b06 100644
}
}
diff --git a/src/bootstrap/compile.rs b/src/bootstrap/compile.rs
-index b581271663..21421b2e38 100644
+index 249a183189..bfc62c762a 100644
--- a/src/bootstrap/compile.rs
+++ b/src/bootstrap/compile.rs
@@ -114,21 +114,6 @@ impl Step for Std {
- fn copy_third_party_objects(builder: &Builder, compiler: &Compiler, target: Interned<String>) {
+ fn copy_third_party_objects(builder: &Builder<'_>, compiler: &Compiler, target: Interned<String>) {
let libdir = builder.sysroot_libdir(*compiler, target);
- // Copies the crt(1,i,n).o startup objects
@@ -150,7 +150,7 @@ index b581271663..21421b2e38 100644
// Copies libunwind.a compiled to be linked wit x86_64-fortanix-unknown-sgx.
//
// This target needs to be linked to Fortanix's port of llvm's libunwind.
-@@ -182,12 +167,6 @@ pub fn std_cargo(builder: &Builder,
+@@ -182,12 +167,6 @@ pub fn std_cargo(builder: &Builder<'_>,
cargo.arg("--features").arg(features)
.arg("--manifest-path")
.arg(builder.src.join("src/libstd/Cargo.toml"));
@@ -164,10 +164,10 @@ index b581271663..21421b2e38 100644
}
diff --git a/src/bootstrap/config.rs b/src/bootstrap/config.rs
-index 9421817ae6..cd70c1a1e4 100644
+index 7d3e584f1a..3f0113e11a 100644
--- a/src/bootstrap/config.rs
+++ b/src/bootstrap/config.rs
-@@ -128,8 +128,6 @@ pub struct Config {
+@@ -132,8 +132,6 @@ pub struct Config {
pub print_step_timings: bool,
pub missing_tools: bool,
@@ -176,7 +176,7 @@ index 9421817ae6..cd70c1a1e4 100644
pub prefix: Option<PathBuf>,
pub sysconfdir: Option<PathBuf>,
pub datadir: Option<PathBuf>,
-@@ -164,7 +162,6 @@ pub struct Target {
+@@ -168,7 +166,6 @@ pub struct Target {
pub linker: Option<PathBuf>,
pub ndk: Option<PathBuf>,
pub crt_static: Option<bool>,
@@ -184,7 +184,7 @@ index 9421817ae6..cd70c1a1e4 100644
pub qemu_rootfs: Option<PathBuf>,
pub no_std: bool,
}
-@@ -296,7 +293,6 @@ struct Rust {
+@@ -304,7 +301,6 @@ struct Rust {
backtrace: Option<bool>,
default_linker: Option<String>,
channel: Option<String>,
@@ -192,7 +192,7 @@ index 9421817ae6..cd70c1a1e4 100644
rpath: Option<bool>,
optimize_tests: Option<bool>,
debuginfo_tests: Option<bool>,
-@@ -335,7 +331,6 @@ struct TomlTarget {
+@@ -343,7 +339,6 @@ struct TomlTarget {
linker: Option<String>,
android_ndk: Option<String>,
crt_static: Option<bool>,
@@ -200,15 +200,15 @@ index 9421817ae6..cd70c1a1e4 100644
qemu_rootfs: Option<String>,
}
-@@ -549,7 +544,6 @@ impl Config {
+@@ -562,7 +557,6 @@ impl Config {
set(&mut config.llvm_tools_enabled, rust.llvm_tools);
- config.rustc_parallel_queries = rust.experimental_parallel_queries.unwrap_or(false);
+ config.rustc_parallel = rust.parallel_compiler.unwrap_or(false);
config.rustc_default_linker = rust.default_linker.clone();
- config.musl_root = rust.musl_root.clone().map(PathBuf::from);
config.save_toolstates = rust.save_toolstates.clone().map(PathBuf::from);
set(&mut config.deny_warnings, rust.deny_warnings.or(flags.warnings));
set(&mut config.backtrace_on_ice, rust.backtrace_on_ice);
-@@ -592,7 +586,6 @@ impl Config {
+@@ -605,7 +599,6 @@ impl Config {
target.ranlib = cfg.ranlib.clone().map(PathBuf::from);
target.linker = cfg.linker.clone().map(PathBuf::from);
target.crt_static = cfg.crt_static.clone();
@@ -217,10 +217,10 @@ index 9421817ae6..cd70c1a1e4 100644
config.target_config.insert(INTERNER.intern_string(triple.clone()), target);
diff --git a/src/bootstrap/configure.py b/src/bootstrap/configure.py
-index b0c3c97024..5128897bf7 100755
+index b2d8f2d8eb..c3bb94938f 100755
--- a/src/bootstrap/configure.py
+++ b/src/bootstrap/configure.py
-@@ -105,28 +105,6 @@ v("aarch64-linux-android-ndk", "target.aarch64-linux-android.android-ndk",
+@@ -109,28 +109,6 @@ v("aarch64-linux-android-ndk", "target.aarch64-linux-android.android-ndk",
"aarch64-linux-android NDK standalone path")
v("x86_64-linux-android-ndk", "target.x86_64-linux-android.android-ndk",
"x86_64-linux-android NDK standalone path")
@@ -250,10 +250,10 @@ index b0c3c97024..5128897bf7 100755
"rootfs in qemu testing, you probably don't want to use this")
v("qemu-aarch64-rootfs", "target.aarch64-unknown-linux-gnu.qemu-rootfs",
diff --git a/src/bootstrap/lib.rs b/src/bootstrap/lib.rs
-index 74c04bac6b..aa91600ea7 100644
+index f1e7f05aa9..4ee1444db3 100644
--- a/src/bootstrap/lib.rs
+++ b/src/bootstrap/lib.rs
-@@ -849,14 +849,6 @@ impl Build {
+@@ -842,14 +842,6 @@ impl Build {
}
}
@@ -265,11 +265,11 @@ index 74c04bac6b..aa91600ea7 100644
- .map(|p| &**p)
- }
-
- /// Returns true if this is a no-std `target`, if defined
+ /// Returns `true` if this is a no-std `target`, if defined
fn no_std(&self, target: Interned<String>) -> Option<bool> {
self.config.target_config.get(&target)
diff --git a/src/bootstrap/sanity.rs b/src/bootstrap/sanity.rs
-index fe547a6b15..a452c874c4 100644
+index ff4fb85bbf..ff45200bde 100644
--- a/src/bootstrap/sanity.rs
+++ b/src/bootstrap/sanity.rs
@@ -169,34 +169,6 @@ pub fn check(build: &mut Build) {
@@ -321,10 +321,10 @@ index ba2d32a929..412c37fdd1 100644
--disable-docs
diff --git a/src/ci/docker/dist-various-1/Dockerfile b/src/ci/docker/dist-various-1/Dockerfile
-index ab2dd5a399..a9569fe6d4 100644
+index f80293b182..52f28df826 100644
--- a/src/ci/docker/dist-various-1/Dockerfile
+++ b/src/ci/docker/dist-various-1/Dockerfile
-@@ -128,13 +128,6 @@ ENV CC_mipsel_unknown_linux_musl=mipsel-openwrt-linux-gcc \
+@@ -130,13 +130,6 @@ ENV CC_mipsel_unknown_linux_musl=mipsel-openwrt-linux-gcc \
CXX_thumbv7neon_unknown_linux_gnueabihf=arm-linux-gnueabihf-g++
ENV RUST_CONFIGURE_ARGS \
@@ -351,10 +351,10 @@ index 06f8a2fbba..f5dd379528 100644
--disable-docs
diff --git a/src/librustc_target/spec/linux_musl_base.rs b/src/librustc_target/spec/linux_musl_base.rs
-index 1bc90d1a73..e26a5240a6 100644
+index e294e63982..58ae91a96a 100644
--- a/src/librustc_target/spec/linux_musl_base.rs
+++ b/src/librustc_target/spec/linux_musl_base.rs
-@@ -3,28 +3,12 @@ use spec::{LinkerFlavor, TargetOptions};
+@@ -3,28 +3,12 @@ use crate::spec::{LinkerFlavor, TargetOptions};
pub fn opts() -> TargetOptions {
let mut base = super::linux_base::opts();