summaryrefslogtreecommitdiff
path: root/user/rust/0011-Use-rustc-workspace-hack-for-rustbook.patch
diff options
context:
space:
mode:
authorSamuel Holland <samuel@sholland.org>2022-04-30 04:27:44 +0000
committerZach van Rijn <me@zv.io>2022-10-21 18:34:01 -0500
commit36ba9dd47f31bfbe4811b03df9a2871c43857219 (patch)
tree2637bf028a2ab8f6e4598f11b1afb84824fdcb64 /user/rust/0011-Use-rustc-workspace-hack-for-rustbook.patch
parent04e62b2391dc7f829349c87e1cc71597731e3c88 (diff)
downloadpackages-36ba9dd47f31bfbe4811b03df9a2871c43857219.tar.gz
packages-36ba9dd47f31bfbe4811b03df9a2871c43857219.tar.bz2
packages-36ba9dd47f31bfbe4811b03df9a2871c43857219.tar.xz
packages-36ba9dd47f31bfbe4811b03df9a2871c43857219.zip
user/rust: Bump to 1.60.0
Signed-off-by: Samuel Holland <samuel@sholland.org>
Diffstat (limited to 'user/rust/0011-Use-rustc-workspace-hack-for-rustbook.patch')
-rw-r--r--user/rust/0011-Use-rustc-workspace-hack-for-rustbook.patch58
1 files changed, 0 insertions, 58 deletions
diff --git a/user/rust/0011-Use-rustc-workspace-hack-for-rustbook.patch b/user/rust/0011-Use-rustc-workspace-hack-for-rustbook.patch
deleted file mode 100644
index 311f2a37f..000000000
--- a/user/rust/0011-Use-rustc-workspace-hack-for-rustbook.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-From 963e5d726f753d1816eae560b99b241934abe786 Mon Sep 17 00:00:00 2001
-From: Samuel Holland <samuel@sholland.org>
-Date: Sun, 6 Oct 2019 17:30:11 -0500
-Subject: [PATCH 11/18] Use rustc-workspace-hack for rustbook
-
-As rustbook now depends transitively on openssl, it needs access to the
-rustc-workspace-hack/all-static feature to pick up openssl-sys/vendored.
-This fixes the rust build with `all-static = true` on systems where
-openssl is not installed (e.g. when cross-compiling).
----
- Cargo.lock | 1 +
- src/bootstrap/tool.rs | 1 +
- src/tools/rustbook/Cargo.toml | 5 +++++
- 3 files changed, 7 insertions(+)
-
-diff --git a/Cargo.lock b/Cargo.lock
-index ab6731e4d43..54177b36827 100644
---- a/Cargo.lock
-+++ b/Cargo.lock
-@@ -2577,6 +2577,7 @@ dependencies = [
- "failure 0.1.5 (registry+https://github.com/rust-lang/crates.io-index)",
- "mdbook 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
- "mdbook-linkcheck 0.3.0 (registry+https://github.com/rust-lang/crates.io-index)",
-+ "rustc-workspace-hack 1.0.0",
- ]
-
- [[package]]
-diff --git a/src/bootstrap/tool.rs b/src/bootstrap/tool.rs
-index df7eb7c455d..c91ccc79aa1 100644
---- a/src/bootstrap/tool.rs
-+++ b/src/bootstrap/tool.rs
-@@ -248,6 +248,7 @@ pub fn prepare_tool_cargo(
- path.ends_with("rls") ||
- path.ends_with("clippy") ||
- path.ends_with("miri") ||
-+ path.ends_with("rustbook") ||
- path.ends_with("rustfmt")
- {
- cargo.env("LIBZ_SYS_STATIC", "1");
-diff --git a/src/tools/rustbook/Cargo.toml b/src/tools/rustbook/Cargo.toml
-index a7188f0d11e..89bbde4d5a9 100644
---- a/src/tools/rustbook/Cargo.toml
-+++ b/src/tools/rustbook/Cargo.toml
-@@ -13,6 +13,11 @@ clap = "2.25.0"
- failure = "0.1"
- mdbook-linkcheck = { version = "0.3.0", optional = true }
-
-+# A noop dependency that changes in the Rust repository, it's a bit of a hack.
-+# See the `src/tools/rustc-workspace-hack/README.md` file in `rust-lang/rust`
-+# for more information.
-+rustc-workspace-hack = "1.0.0"
-+
- [dependencies.mdbook]
- version = "0.3.0"
- default-features = false
---
-2.21.0
-