summaryrefslogtreecommitdiff
path: root/user/rust/0015-Ignore-broken-and-non-applicable-tests.patch
diff options
context:
space:
mode:
authorSamuel Holland <samuel@sholland.org>2019-10-07 00:01:16 +0000
committerSamuel Holland <samuel@sholland.org>2019-10-14 22:36:45 -0500
commit3febb3d8330926d97e865c3aeaddff95acef8b83 (patch)
tree08b9bb19c509e2093a12b7bd53a2ac51769134f6 /user/rust/0015-Ignore-broken-and-non-applicable-tests.patch
parentb5b897e47ab11998c46db7f9ba96410a187c0634 (diff)
downloadpackages-3febb3d8330926d97e865c3aeaddff95acef8b83.tar.gz
packages-3febb3d8330926d97e865c3aeaddff95acef8b83.tar.bz2
packages-3febb3d8330926d97e865c3aeaddff95acef8b83.tar.xz
packages-3febb3d8330926d97e865c3aeaddff95acef8b83.zip
user/rust: Bump to 1.38.0
Signed-off-by: Samuel Holland <samuel@sholland.org>
Diffstat (limited to 'user/rust/0015-Ignore-broken-and-non-applicable-tests.patch')
-rw-r--r--user/rust/0015-Ignore-broken-and-non-applicable-tests.patch104
1 files changed, 104 insertions, 0 deletions
diff --git a/user/rust/0015-Ignore-broken-and-non-applicable-tests.patch b/user/rust/0015-Ignore-broken-and-non-applicable-tests.patch
new file mode 100644
index 000000000..bae3eb94d
--- /dev/null
+++ b/user/rust/0015-Ignore-broken-and-non-applicable-tests.patch
@@ -0,0 +1,104 @@
+From 7a797219b4604eb039387d188b22ee9b292bf68a Mon Sep 17 00:00:00 2001
+From: Samuel Holland <samuel@sholland.org>
+Date: Sun, 16 Sep 2018 16:38:48 +0000
+Subject: [PATCH 15/18] Ignore broken and non-applicable tests
+
+c-link-to-rust-va-list-fn: unstable feature, broken on aarch64, #56475
+env-funky-keys: can't handle LD_PRELOAD (e.g. sandbox)
+long-linker-command-lines: takes >10 minutes to run (but still passes)
+simd-intrinsic-generic-bitmask.rs: broken on BE, #59356
+sparc-struct-abi: no sparc target
+sysroot-crates-are-unstable: can't run rustc without RPATH
+---
+ src/test/codegen/sparc-struct-abi.rs | 1 +
+ src/test/run-make-fulldeps/c-link-to-rust-va-list-fn/Makefile | 2 ++
+ src/test/run-make-fulldeps/linker-output-non-utf8/Makefile | 2 ++
+ src/test/run-make-fulldeps/long-linker-command-lines/Makefile | 2 ++
+ src/test/run-make-fulldeps/sysroot-crates-are-unstable/Makefile | 2 ++
+ src/test/ui/env-funky-keys.rs | 1 +
+ src/test/ui/simd/simd-intrinsic-generic-bitmask.rs | 2 ++
+ 7 files changed, 12 insertions(+)
+
+diff --git a/src/test/codegen/sparc-struct-abi.rs b/src/test/codegen/sparc-struct-abi.rs
+index 78e5b14a212..6f93e93286b 100644
+--- a/src/test/codegen/sparc-struct-abi.rs
++++ b/src/test/codegen/sparc-struct-abi.rs
+@@ -4,6 +4,7 @@
+
+ // only-sparc64
+ // compile-flags: -O --target=sparc64-unknown-linux-gnu --crate-type=rlib
++// ignore-test
+ #![feature(no_core, lang_items)]
+ #![no_core]
+
+diff --git a/src/test/run-make-fulldeps/c-link-to-rust-va-list-fn/Makefile b/src/test/run-make-fulldeps/c-link-to-rust-va-list-fn/Makefile
+index f124ca2ab61..363b18f0985 100644
+--- a/src/test/run-make-fulldeps/c-link-to-rust-va-list-fn/Makefile
++++ b/src/test/run-make-fulldeps/c-link-to-rust-va-list-fn/Makefile
+@@ -1,3 +1,5 @@
++# ignore-aarch64
++
+ -include ../tools.mk
+
+ all:
+diff --git a/src/test/run-make-fulldeps/linker-output-non-utf8/Makefile b/src/test/run-make-fulldeps/linker-output-non-utf8/Makefile
+index b47ce17ec8b..59c44fcf438 100644
+--- a/src/test/run-make-fulldeps/linker-output-non-utf8/Makefile
++++ b/src/test/run-make-fulldeps/linker-output-non-utf8/Makefile
+@@ -13,6 +13,8 @@
+ # This also does not work on Apple APFS due to the filesystem requiring
+ # valid UTF-8 paths.
+
++# ignore-musl
++
+ # The zzz it to allow humans to tab complete or glob this thing.
+ bad_dir := $(TMPDIR)/zzz$$'\xff'
+
+diff --git a/src/test/run-make-fulldeps/long-linker-command-lines/Makefile b/src/test/run-make-fulldeps/long-linker-command-lines/Makefile
+index 5876fbc94bc..5f167ece1a2 100644
+--- a/src/test/run-make-fulldeps/long-linker-command-lines/Makefile
++++ b/src/test/run-make-fulldeps/long-linker-command-lines/Makefile
+@@ -1,3 +1,5 @@
++# ignore-test
++
+ -include ../tools.mk
+
+ all:
+diff --git a/src/test/run-make-fulldeps/sysroot-crates-are-unstable/Makefile b/src/test/run-make-fulldeps/sysroot-crates-are-unstable/Makefile
+index 9e770706857..6d92ec5cec8 100644
+--- a/src/test/run-make-fulldeps/sysroot-crates-are-unstable/Makefile
++++ b/src/test/run-make-fulldeps/sysroot-crates-are-unstable/Makefile
+@@ -1,3 +1,5 @@
++# ignore-test
++
+ -include ../tools.mk
+
+ all:
+diff --git a/src/test/ui/env-funky-keys.rs b/src/test/ui/env-funky-keys.rs
+index 4faceb53266..09764dc32bf 100644
+--- a/src/test/ui/env-funky-keys.rs
++++ b/src/test/ui/env-funky-keys.rs
+@@ -1,6 +1,7 @@
+ // run-pass
+ // Ignore this test on Android, because it segfaults there.
+
++// ignore-test
+ // ignore-android
+ // ignore-windows
+ // ignore-cloudabi no execve
+diff --git a/src/test/ui/simd/simd-intrinsic-generic-bitmask.rs b/src/test/ui/simd/simd-intrinsic-generic-bitmask.rs
+index b28f742a92e..3ee4ccce731 100644
+--- a/src/test/ui/simd/simd-intrinsic-generic-bitmask.rs
++++ b/src/test/ui/simd/simd-intrinsic-generic-bitmask.rs
+@@ -2,6 +2,8 @@
+ #![allow(non_camel_case_types)]
+
+ // ignore-emscripten
++// ignore-powerpc
++// ignore-powerpc64
+
+ // Test that the simd_bitmask intrinsic produces correct results.
+
+--
+2.21.0
+