summaryrefslogtreecommitdiff
path: root/user/rust/0024-Ignore-broken-and-non-applicable-tests.patch
diff options
context:
space:
mode:
authorSamuel Holland <samuel@sholland.org>2018-09-19 02:31:46 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-09-25 00:08:16 +0000
commitcd980d29292f8f5d6bb8bef5773ce91b95bfb90a (patch)
tree7eeb0fd1825894538eea675625a9f3009f3fca9d /user/rust/0024-Ignore-broken-and-non-applicable-tests.patch
parent63266fdc6f2014cc6dfd0f983e13de7c378bc708 (diff)
downloadpackages-cd980d29292f8f5d6bb8bef5773ce91b95bfb90a.tar.gz
packages-cd980d29292f8f5d6bb8bef5773ce91b95bfb90a.tar.bz2
packages-cd980d29292f8f5d6bb8bef5773ce91b95bfb90a.tar.xz
packages-cd980d29292f8f5d6bb8bef5773ce91b95bfb90a.zip
user/rust: new package
Diffstat (limited to 'user/rust/0024-Ignore-broken-and-non-applicable-tests.patch')
-rw-r--r--user/rust/0024-Ignore-broken-and-non-applicable-tests.patch63
1 files changed, 63 insertions, 0 deletions
diff --git a/user/rust/0024-Ignore-broken-and-non-applicable-tests.patch b/user/rust/0024-Ignore-broken-and-non-applicable-tests.patch
new file mode 100644
index 000000000..75434c9fb
--- /dev/null
+++ b/user/rust/0024-Ignore-broken-and-non-applicable-tests.patch
@@ -0,0 +1,63 @@
+From 4ed9e0630eafd839c9b22e8ed56ecacccc913bdf Mon Sep 17 00:00:00 2001
+From: Samuel Holland <samuel@sholland.org>
+Date: Sun, 16 Sep 2018 16:38:48 +0000
+Subject: [PATCH 24/28] Ignore broken and non-applicable tests
+
+long-linker-command-lines: takes more than 10 minutes to run
+nil-enum: GDB output changed in a questionable way
+sparc-struct-abi: no sparc target
+sysroot-crates-are-unstable: can't run rustc without rpath
+---
+ src/test/codegen/sparc-struct-abi.rs | 1 +
+ src/test/debuginfo/nil-enum.rs | 2 +-
+ src/test/run-make-fulldeps/long-linker-command-lines/Makefile | 1 -
+ src/test/run-make-fulldeps/sysroot-crates-are-unstable/Makefile | 2 +-
+ 4 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/test/codegen/sparc-struct-abi.rs b/src/test/codegen/sparc-struct-abi.rs
+index d3b7a5cd59..5e0f94cdf9 100644
+--- a/src/test/codegen/sparc-struct-abi.rs
++++ b/src/test/codegen/sparc-struct-abi.rs
+@@ -12,6 +12,7 @@
+ // See issue #52638.
+
+ // compile-flags: -O --target=sparc64-unknown-linux-gnu --crate-type=rlib
++// ignore-test
+ #![feature(no_core, lang_items)]
+ #![no_core]
+
+diff --git a/src/test/debuginfo/nil-enum.rs b/src/test/debuginfo/nil-enum.rs
+index 94377421c0..bce2b98447 100644
+--- a/src/test/debuginfo/nil-enum.rs
++++ b/src/test/debuginfo/nil-enum.rs
+@@ -10,7 +10,7 @@
+
+ // LLDB can't handle zero-sized values
+ // ignore-lldb
+-
++// ignore-test
+
+ // compile-flags:-g
+ // gdb-command:run
+diff --git a/src/test/run-make-fulldeps/long-linker-command-lines/Makefile b/src/test/run-make-fulldeps/long-linker-command-lines/Makefile
+index 5876fbc94b..e9f5c33b77 100644
+--- a/src/test/run-make-fulldeps/long-linker-command-lines/Makefile
++++ b/src/test/run-make-fulldeps/long-linker-command-lines/Makefile
+@@ -2,4 +2,3 @@
+
+ all:
+ $(RUSTC) foo.rs -g -O
+- RUSTC="$(RUSTC_ORIGINAL)" $(call RUN,foo)
+diff --git a/src/test/run-make-fulldeps/sysroot-crates-are-unstable/Makefile b/src/test/run-make-fulldeps/sysroot-crates-are-unstable/Makefile
+index 9e77070685..7784230b46 100644
+--- a/src/test/run-make-fulldeps/sysroot-crates-are-unstable/Makefile
++++ b/src/test/run-make-fulldeps/sysroot-crates-are-unstable/Makefile
+@@ -1,4 +1,4 @@
+ -include ../tools.mk
+
+ all:
+- env '$(HOST_RPATH_ENV)' python2.7 test.py
++ true
+--
+2.18.0
+