summaryrefslogtreecommitdiff
path: root/user/rust/APKBUILD
diff options
context:
space:
mode:
authorSamuel Holland <samuel@sholland.org>2019-10-07 00:01:16 +0000
committerSamuel Holland <samuel@sholland.org>2019-10-14 22:36:45 -0500
commit3febb3d8330926d97e865c3aeaddff95acef8b83 (patch)
tree08b9bb19c509e2093a12b7bd53a2ac51769134f6 /user/rust/APKBUILD
parentb5b897e47ab11998c46db7f9ba96410a187c0634 (diff)
downloadpackages-3febb3d8330926d97e865c3aeaddff95acef8b83.tar.gz
packages-3febb3d8330926d97e865c3aeaddff95acef8b83.tar.bz2
packages-3febb3d8330926d97e865c3aeaddff95acef8b83.tar.xz
packages-3febb3d8330926d97e865c3aeaddff95acef8b83.zip
user/rust: Bump to 1.38.0
Signed-off-by: Samuel Holland <samuel@sholland.org>
Diffstat (limited to 'user/rust/APKBUILD')
-rw-r--r--user/rust/APKBUILD118
1 files changed, 50 insertions, 68 deletions
diff --git a/user/rust/APKBUILD b/user/rust/APKBUILD
index 50608079b..fd6dd9125 100644
--- a/user/rust/APKBUILD
+++ b/user/rust/APKBUILD
@@ -3,16 +3,15 @@
# Contributor: Jeizsm <jeizsm@gmail.com>
# Maintainer: Samuel Holland <samuel@sholland.org>
pkgname=rust
-pkgver=1.37.0
-_bootcargover=0.37.0
-_bootver=1.36.0
+pkgver=1.38.0
+_bootver=1.37.0
_llvmver=8
pkgrel=0
pkgdesc="The Rust Programming Language"
url="https://www.rust-lang.org"
arch="all"
license="(Apache-2.0 OR MIT) AND (NCSA OR MIT) AND BSD-2-Clause AND BSD-3-Clause"
-depends="$pkgname-stdlib=$pkgver-r$pkgrel gcc musl-dev"
+depends="$pkgname-std=$pkgver-r$pkgrel gcc musl-dev"
makedepends="
curl-dev
libgit2-dev
@@ -22,11 +21,13 @@ makedepends="
openssl-dev
python3
zlib-dev
+ cargo-bootstrap~$_bootver
+ $pkgname-bootstrap~$_bootver
"
provides="$pkgname-bootstrap=$pkgver-r$pkgrel"
subpackages="
$pkgname-dbg
- $pkgname-stdlib
+ $pkgname-std
$pkgname-analysis
$pkgname-doc
$pkgname-gdb::noarch
@@ -43,9 +44,6 @@ subpackages="
rustfmt
"
source="https://static.rust-lang.org/dist/rustc-$pkgver-src.tar.xz
- https://distfiles.adelielinux.org/source/rust/cargo-$_bootcargover-$CBUILD.tar.xz
- https://distfiles.adelielinux.org/source/rust/rust-std-$_bootver-$CBUILD.tar.xz
- https://distfiles.adelielinux.org/source/rust/rustc-$_bootver-$CBUILD.tar.xz
0001-Don-t-pass-CFLAGS-to-the-C-compiler.patch
0002-Fix-LLVM-build.patch
0003-Allow-rustdoc-to-work-when-cross-compiling-on-musl.patch
@@ -56,44 +54,30 @@ source="https://static.rust-lang.org/dist/rustc-$pkgver-src.tar.xz
0008-Fix-zero-sized-aggregate-ABI-on-powerpc.patch
0009-compiletest-Match-suffixed-environments.patch
0010-test-c-variadic-Fix-patterns-on-powerpc64.patch
- 0011-test-use-extern-for-plugins-Don-t-assume-multilib.patch
- 0012-test-sysroot-crates-are-unstable-Fix-test-when-rpath.patch
- 0013-Ignore-broken-and-non-applicable-tests.patch
- 0014-Link-stage-2-tools-dynamically-to-libstd.patch
- 0015-Move-debugger-scripts-to-usr-share-rust.patch
- 0016-Add-foxkit-target-specs.patch
+ 0011-Use-rustc-workspace-hack-for-rustbook.patch
+ 0012-test-failed-doctest-output-Fix-normalization.patch
+ 0013-test-use-extern-for-plugins-Don-t-assume-multilib.patch
+ 0014-test-sysroot-crates-are-unstable-Fix-test-when-rpath.patch
+ 0015-Ignore-broken-and-non-applicable-tests.patch
+ 0016-Link-stage-2-tools-dynamically-to-libstd.patch
+ 0017-Move-debugger-scripts-to-usr-share-rust.patch
+ 0018-Add-foxkit-target-specs.patch
0030-libc-linkage.patch
0031-typenum-pmmx.patch
+ 0032-libgit2-sys-abi.patch
0040-rls-atomics.patch
"
builddir="$srcdir/rustc-$pkgver-src"
_rlibdir="/usr/lib/rustlib/$CTARGET/lib"
-prepare() {
- default_prepare
-
- $srcdir/cargo-$_bootcargover-$CBUILD/install.sh \
- --destdir=$srcdir/prebuilt \
- --prefix=/ \
- --disable-ldconfig
- $srcdir/rust-std-$_bootver-$CBUILD/install.sh \
- --destdir=$srcdir/prebuilt \
- --prefix=/ \
- --disable-ldconfig
- $srcdir/rustc-$_bootver-$CBUILD/install.sh \
- --destdir=$srcdir/prebuilt \
- --prefix=/ \
- --disable-ldconfig
-}
-
build() {
cat > config.toml <<- EOF
[build]
build = "$CBUILD"
host = [ "$CHOST" ]
target = [ "$CTARGET" ]
- cargo = "$srcdir/prebuilt/bin/cargo"
- rustc = "$srcdir/prebuilt/bin/rustc"
+ cargo = "/usr/bin/cargo"
+ rustc = "/usr/bin/rustc"
submodules = false
python = "python3"
locked-deps = true
@@ -137,7 +121,6 @@ build() {
check() {
LIBGIT2_SYS_USE_PKG_CONFIG=1 \
LLVM_LINK_SHARED=1 \
- RUST_BACKTRACE=1 \
python3 x.py test -j ${JOBS:-2} --no-doc --no-fail-fast \
src/test/codegen \
src/test/codegen-units \
@@ -146,13 +129,12 @@ check() {
src/test/mir-opt \
src/test/pretty \
src/test/run-fail \
- src/test/run-fail/pretty \
src/test/run-make \
src/test/run-make-fulldeps \
- src/test/run-pass \
- src/test/run-pass/pretty \
- src/test/run-pass-fulldeps \
- src/test/run-pass-fulldeps/pretty \
+ src/test/rustdoc \
+ src/test/rustdoc-js \
+ src/test/rustdoc-js-std \
+ src/test/rustdoc-ui \
src/test/ui \
src/test/ui-fulldeps
}
@@ -180,7 +162,7 @@ package() {
"$pkgdir"/usr/lib/rustlib/uninstall.sh
}
-stdlib() {
+std() {
pkgdesc="Standard library for Rust"
depends="musl-utils"
@@ -192,7 +174,7 @@ stdlib() {
analysis() {
pkgdesc="Compiler analysis data for the Rust standard library"
- depends="$pkgname=$pkgver-r$pkgrel $pkgname-stdlib=$pkgver-r$pkgrel"
+ depends="$pkgname=$pkgver-r$pkgrel $pkgname-std=$pkgver-r$pkgrel"
_mv "$pkgdir"${_rlibdir%/*}/analysis "$subpkgdir"${_rlibdir%/*}
}
@@ -232,14 +214,14 @@ src() {
cargo() {
pkgdesc="The Rust package manager"
provides="cargo-bootstrap=$pkgver-r$pkgrel"
- depends="$pkgname-stdlib=$pkgver-r$pkgrel $pkgname"
+ depends="$pkgname-std=$pkgver-r$pkgrel $pkgname"
_mv "$pkgdir"/usr/bin/cargo "$subpkgdir"/usr/bin
}
_cargo_clippy() {
pkgdesc="A collection of Rust lints (cargo plugin)"
- depends="$pkgname-stdlib=$pkgver-r$pkgrel cargo"
+ depends="$pkgname-std=$pkgver-r$pkgrel cargo"
_mv "$pkgdir"/usr/bin/cargo-clippy \
"$pkgdir"/usr/bin/clippy-driver \
@@ -248,7 +230,7 @@ _cargo_clippy() {
_cargo_fmt() {
pkgdesc="Format Rust code (cargo plugin)"
- depends="$pkgname-stdlib=$pkgver-r$pkgrel cargo rustfmt"
+ depends="$pkgname-std=$pkgver-r$pkgrel cargo rustfmt"
install_if="cargo=$pkgver-r$pkgrel rustfmt=$pkgver-r$pkgrel"
_mv "$pkgdir"/usr/bin/cargo-fmt "$subpkgdir"/usr/bin
@@ -290,7 +272,7 @@ _cargo_doc() {
miri() {
pkgdesc="An interpreter for Rust's mid-level intermediate representation"
license="Apache-2.0 OR MIT"
- depends="$pkgname-stdlib=$pkgver-r$pkgrel"
+ depends="$pkgname-std=$pkgver-r$pkgrel"
_mv "$pkgdir"/usr/bin/miri "$subpkgdir"/usr/bin
}
@@ -298,14 +280,14 @@ miri() {
rls() {
pkgdesc="The Rust language server"
license="Apache-2.0 OR MIT"
- depends="$pkgname-stdlib=$pkgver-r$pkgrel"
+ depends="$pkgname-std=$pkgver-r$pkgrel"
_mv "$pkgdir"/usr/bin/rls "$subpkgdir"/usr/bin
}
rustfmt() {
pkgdesc="Format Rust code"
- depends="$pkgname-stdlib=$pkgver-r$pkgrel"
+ depends="$pkgname-std=$pkgver-r$pkgrel"
_mv "$pkgdir"/usr/bin/rustfmt "$subpkgdir"/usr/bin
}
@@ -316,26 +298,26 @@ _mv() {
mv "$@"
}
-sha512sums="bfee43f578e6d44ead950b870b9fd31087e1bd3f917611f5dce7ad56504b83185edf43e297e8d1304e9e97b9a580d1e6adf6608ab8ed6dee0dc8c5153cdbc5d4 rustc-1.37.0-src.tar.xz
-ab0711dafeae76d9718a0c6aaf118f512d295c66191d96198acc3591f5412d4ee6c50ad5cc56df8f1f32a2be3c4d9bb5ead798c6b9f4089c0a624e09825dd6be cargo-0.37.0-powerpc-foxkit-linux-musl.tar.xz
-aa97abeccf03d3368b60731845d23ff74fb962818b7d1e6ada2e9a647b442a1b824541402f3a883c9be6e1f8db94ca98244fc4009ff0386403c57f999bd6d263 rust-std-1.36.0-powerpc-foxkit-linux-musl.tar.xz
-5078bdd341b145119ba3396892cd8f63c65fafb1b041674e350b2cc02376fd2c32799baca85e916522c34c416a6c67d9d92bf8f44abb575a1ae1fedc4726516e rustc-1.36.0-powerpc-foxkit-linux-musl.tar.xz
-5b765a47a49cbab26e5093ebf6dce5b8e3463ebdb0e404b9c952fef7993fd57e9a0d9f7d301c97b76b8bd35e4ea8b72c8768aa384cd215c2a12ddd45727343f8 0001-Don-t-pass-CFLAGS-to-the-C-compiler.patch
-9b711ee16eed20a0293c1ca6d96c48db3fae5f2f60fdcb04ae2d1acfdc8036fa3b41ca799717aa14279fd7b7db0090861bceddeafd8d41f70433039e4983d9c8 0002-Fix-LLVM-build.patch
-7f61bdc7c754379e1675d2f102f1f60f4c29ca2a2293d70741db46a0f29d61008d067166c7576cd0e5fa3c26e811e711e851b22f7df69974a7b53fa316c33777 0003-Allow-rustdoc-to-work-when-cross-compiling-on-musl.patch
-0f1989e4db3a48fe8718002a58aaecf359bc65bf5a6dae327c062fce0b8a3176a6b70c80c72118d5fcabbc16b67b986ce67ab1fda13ca52899ca320716f3e606 0004-Require-static-native-libraries-when-linking-static-.patch
-b27045eb7809438db988979843f68ddfee46a6f889b0fbaaed401b249d6e224940e9d15143e55f8b2df911a8fa24dfec81da0f064b47a86f3ed24010aee309e3 0005-Remove-nostdlib-and-musl_root-from-musl-targets.patch
-4662f036e037b99178bb24c32524211eb5fc10ac711d16f13ddb933db84811eab3149cbe943521536d00c765eade1c1df01ca7e8f4fee69fca540546c0fbe806 0006-Prefer-libgcc_eh-over-libunwind-for-musl.patch
-8742ff1c442dc2c7baad528fd6c51e202d091f24fbd7ac1350241a729a20f6f90818b76bb4de0b36b09afdeaad89b54843f08fb474e2232854cb68cd3d6a57b5 0007-Fix-C-aggregate-passing-ABI-on-powerpc.patch
-8eb5c08701cfcdc14ece1c40fa2276e760283ce9228c96ff1dedb5256dcec307c3705a8e27ac1bd767184d0acfc835b9b0b4f02d5fa7ec24a75f04014e67ec61 0008-Fix-zero-sized-aggregate-ABI-on-powerpc.patch
-20f794339f7a9c048dad2f39b5a3dad9293b07ba0b130354c0e74ec71088d2f2c24f6630543e8e5a41b244c8c1013249403ce8acf1fc2c2b4ab5065049f7f04e 0009-compiletest-Match-suffixed-environments.patch
-d3d3250d762b482c93679cbc7a1d5ccf2eb803e271b840a5d426cf77d58d2cb53fd76baf46bfbaf7674c5ef9f18133cf0b48be08864c002171f3547aaa377bd6 0010-test-c-variadic-Fix-patterns-on-powerpc64.patch
-d01d27d6f344fd30f75e7acd8f1b967eda382f7ee6387f8b0c52aa1ab083d5d86fa9d8d424c3e2b792502e75df03bacc58bd24ed4e448cfefe6bbfbb57586b06 0011-test-use-extern-for-plugins-Don-t-assume-multilib.patch
-e25a4ba32b3b6fbc774c341bb3bda481a9f86917204e7c9bd69f34e2a72b4b3e58256d0619a94ce1d0f4cc17913d7216974b86fe96a776ba4260d0a01dcacaa9 0012-test-sysroot-crates-are-unstable-Fix-test-when-rpath.patch
-68f7b35980c7b4b7088e28a7350c847656d4ffecbcec125ac6790a057a8a735563739f0ade8a7cf0283844cd1655114fa7ad6be106993e34b66e520aed34dd6d 0013-Ignore-broken-and-non-applicable-tests.patch
-b6d4ce58e540373da797c89ed2ca3b23a8504511ee6bb6d0c52bd04273498aab10c99baf6f4633bb5a246c2612a7a538cbfed494bf901afdc6688f937234b4ac 0014-Link-stage-2-tools-dynamically-to-libstd.patch
-fc10130544f7ceda378a9e7fb03a0dc4ea32a6d031061eada60af2d1c688d94f38ab31aad74f8f11b8aec2614415befa2c5e9789eeaf73b998f39b9677886155 0015-Move-debugger-scripts-to-usr-share-rust.patch
-2c11c4bee3c6d10de6c2a9937bf3901f4c60dd1d9c50fcf57daa182a9b4d7b40d27632d3ef31ef083ae7903fcd49fdd41413ab8de1021f7d857884b9ac53c724 0016-Add-foxkit-target-specs.patch
-7642e95d7f5e5d167a2f3e1300fc63f7bf34b6c0667b4e43e7c2378acd8c293f82d7c5651dfb75b03d717c0c5c369911f595dc641a629024e615d443244e6da1 0030-libc-linkage.patch
+sha512sums="b756d29a7a222bc7b5c7f42ff397346ab840f78e559f93e6e36b65e76eea525cf429899fe4de9fb8966623a2225b552feef9fa831bee50f9e25c976fa2af8c0a rustc-1.38.0-src.tar.xz
+79ca3a7dcb2e448ab5798f1cfc62bba833c947dad684521c3c77b233ca3ce27301e706848f1b05c3405ebc843684f47a7809d2d9782b4f11be8c9941e1153027 0001-Don-t-pass-CFLAGS-to-the-C-compiler.patch
+61a7072b554f8e90e65f1b1e9975f7359b8523026129003a51cb216b54d8fe2ffaa6ef6ee5aeb4defcc28fb5b2d874314c61988875bc86edfdaf706efab67cd9 0002-Fix-LLVM-build.patch
+30404faeb82fa8236a481c91ba29c6ac6d4276140702164af3ec91eaaa4d13c547f2fce245ac0220a5a64ccc7c79818c2e5d70900f63fa17356e906a5b309915 0003-Allow-rustdoc-to-work-when-cross-compiling-on-musl.patch
+7b1a77764d67c48a2c9054731dff0f245b70c249ff53cdaa0d4c26f6d01ae9522302bc487b889d22c9b82a926cbf08d938a4886e5197ea814d2b0a0f0066cd6e 0004-Require-static-native-libraries-when-linking-static-.patch
+9a9d413cf866c44e1eadf51c736d376e87c83cdbee9509526666b01e73030e4e10ced0aca1b8575955f7dd90eb4b246e929ab36a624e212c8ff0ecf726914948 0005-Remove-nostdlib-and-musl_root-from-musl-targets.patch
+4183bc73eaa4195d6fbfa79caf4c7bdc5ce9f29eb9e023b11252bd57f3e5daa4ea19753f7bad7db2f7872788e2dfe821aa50c7b1d63cbe42cd024742062f27b5 0006-Prefer-libgcc_eh-over-libunwind-for-musl.patch
+177d54428bb200b6ab08c3ac1abd763c794494b80f25fa81732f1b355ecc0d3cb3ebb187fbc919aea2844577991fb66c308da27453ab1a21529dd6f70f2d2f90 0007-Fix-C-aggregate-passing-ABI-on-powerpc.patch
+ad2b8d030576538a59498bbc529da7e4839b3d85d37981c83565ecd8605c0a797d1fc355a01ea05ff617ed6b6bd4c9f344420e9e8bf10374318d1de6df712a94 0008-Fix-zero-sized-aggregate-ABI-on-powerpc.patch
+aefc44d8610436be9040329cf13fbe5c36f542b2124b533b6797fe239dcf706d004c73e319226ac19fb790c0114cdd3a49e153f66a154804dc84064cbcb32f70 0009-compiletest-Match-suffixed-environments.patch
+489b97af8624a434b8267a52c88f1ab2a9f75c668148feb5a6570aaf9696b92cc49946b628089a9e56f22a7e35e6c9b9d1844505a024da14520ae420001c4734 0010-test-c-variadic-Fix-patterns-on-powerpc64.patch
+d4711810dff2c59884efb2a141b5bbbdd43041d94b878b69b7fe9667b20e207851403ae1d5c1e100c4f17436bd1b82500207e8a45be5f7dc49449faae7b8d539 0011-Use-rustc-workspace-hack-for-rustbook.patch
+f12a6eda193bb8d1bdfae568ade26de519e6d80ffa149ef31f64d052e44eeff3ce46220fe594118d4e4cf277eda19949636472b300226fb1e38ff70a214cbdea 0012-test-failed-doctest-output-Fix-normalization.patch
+ae3fb54e0ec3a504cd58ad27159f00d2269266efd8723351df84e1c38d8345fa5ab85a0964b69cd6f0ccca1aa01a92c61f284a97fee7c0a299c1808251a48289 0013-test-use-extern-for-plugins-Don-t-assume-multilib.patch
+3ed7fda61e943a110f9c5caa2b5015704f49c18139c86ec3d187faf9191703e5003c16c462e455b2bf889e0c0f7f137de52d8cfa283e78b174089297a89f9a1f 0014-test-sysroot-crates-are-unstable-Fix-test-when-rpath.patch
+4605c006c6b389672227b836b43e3cecdf808977d3502d0dd335f996ca51aaf5f0993ab23027f523e8b81baeb2ad9aba2775137e445698cf5526f41f0a4689d3 0015-Ignore-broken-and-non-applicable-tests.patch
+5be32ec3b3dcbdf8061c57c68a6496b16e049cbcdcc5e17f75a9f76e41d5c309f4c8655ec8af3e2870c3426ded69b64878baad8e565222ea58fdf76b460f32c9 0016-Link-stage-2-tools-dynamically-to-libstd.patch
+e8415a50fb981d8bff795ad1c869a791250401e8925f3a89e4b67badcb23938e9f39917bf0bcc298c29f13dc98e48ae1131f79af3cbdb1af3733b7f03ad579af 0017-Move-debugger-scripts-to-usr-share-rust.patch
+3fc66d68c316300eafdbdf622aadb8afdbe9b4f8b110db40cac327692ed869b34a623448c3e4409a5bf2c53479a05359ecaa87c8bb65c3939c71346542aeafcf 0018-Add-foxkit-target-specs.patch
+453dd39ae08b8fa633016d9a69a675b26edd86c2a881a3f30562f29e5098b86b4ad64804f453c0f9150696315f084555eb6d0c7aad3e72381f8844c7fc27b5ef 0030-libc-linkage.patch
0cb12e9165d198c1e04b258454dbaf5459e192ad24d64c9fa132ebe0f1bcd5da3550eae8dfdaa792fa809b505af62964ecf0219dc4373420ee8ad3e111539a09 0031-typenum-pmmx.patch
+ccf6b0f91e39d247c296f5a4330d5dd36385cb58dea6987e8b0d31cc8aa6d6612e6c86a4b2576bde4be026048058dccb71fb87e68e7f72a7e7a4360ce4dce7f5 0032-libgit2-sys-abi.patch
ab35bacf45ef5e46be110a8d27867fd4d5deb23cd5cbe8dc7f1da2177469945f9254f2a7915ee4fc430468a4421623429f0a01eb9eba14e047384efe3d3ec152 0040-rls-atomics.patch"