summaryrefslogtreecommitdiff
path: root/user/rust
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-02-23 02:36:46 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-02-23 02:36:46 +0000
commit45e7d514d268115d6c1e0075d0d5884da65379c5 (patch)
treef1f00307646ab1560a4254ac498f15d96e5f0e26 /user/rust
parent88924496c2ce4d6b1eb3bbd42dfa5a5a259ef4cd (diff)
downloadpackages-45e7d514d268115d6c1e0075d0d5884da65379c5.tar.gz
packages-45e7d514d268115d6c1e0075d0d5884da65379c5.tar.bz2
packages-45e7d514d268115d6c1e0075d0d5884da65379c5.tar.xz
packages-45e7d514d268115d6c1e0075d0d5884da65379c5.zip
user/qastools: new package
Diffstat (limited to 'user/rust')
-rw-r--r--user/rust/APKBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/user/rust/APKBUILD b/user/rust/APKBUILD
index 1921a4306..8534e1112 100644
--- a/user/rust/APKBUILD
+++ b/user/rust/APKBUILD
@@ -115,7 +115,7 @@ build() {
codegen-units = 1
debuginfo = true
debuginfo-lines = true
- debuginfo-only-std = false
+ debuginfo-only-std = true
debuginfo-tools = true
use-jemalloc = false
backtrace = true
@@ -138,6 +138,7 @@ build() {
check() {
cd "$builddir"
+ RUST_BACKTRACE=1 \
./x.py test -j ${JOBS:-2} --no-doc --no-fail-fast \
src/test/codegen \
src/test/codegen-units \
@@ -301,9 +302,9 @@ _mv() {
mv "$@"
}
sha512sums="d6688711452295c41468af214f036499074d82fbeedc3f03560275219c2fae910e623e38e3210176d86f78ba5533ea098da5ff21532c8ad1a5aac132bb74ee02 rustc-1.31.1-src.tar.xz
-c414a250edcf5b9c390137a01dc728f22e3067adab43f91bc06a4bed7580bf0e6171e4a844167b5c4bc13774c9ef9e33e1f5cab018dac8b3df6d630a9a163e2c cargo-0.31.0-powerpc64-foxkit-linux-musl.tar.xz
-c6eeb91d7de95401d118d287435ac24e014711f73e86fab7da0a082d7cf03abfe137563cfe6a88b1309cdb0fec11acfceac01cc3bbc2e83650026230ce0cf079 rust-std-1.30.1-powerpc64-foxkit-linux-musl.tar.xz
-f6099a632de0b4201c3d4639a9c32244fb2fccee891af13fc7efdbaf546e37a67c80b0bce92a19ad746349c59a3627fded64ebcace34fb33c2773bb4aa799cfb rustc-1.30.1-powerpc64-foxkit-linux-musl.tar.xz
+16596561ff87c66f64f4b40602184355d3695822b9b9e6e0e929f340664718698e6f5b378c9162b48f9cb180be5fd8e583e5e51a1c57c1cd55dcc80f468cb509 cargo-0.31.0-powerpc-foxkit-linux-musl.tar.xz
+cdfc7a3d51d66338f31007daafab95570e4e465983add99db7a45f1a3e601588b19e1257fe3e7fcc6b7104ba445add2fa1cda71325a9ab6d196b4ad0dcef2fb5 rust-std-1.30.1-powerpc-foxkit-linux-musl.tar.xz
+190ed9d84513a229f389fc5d1bf0b8e22202bd3b9802330ee2844c436ae13700bdaded091498be4f2c4c65b2f6ef55c1e2db41a918747ac60e8e11e331be2c29 rustc-1.30.1-powerpc-foxkit-linux-musl.tar.xz
acab7c5ffa73cd83cf3ae23e69d2c05ccc3ca03aa4d5a15179af76f2e75b7c5a1bc8d2969c0a9a4b5ad36a50a8cce283e62db878797be6d0da252b414de004cd 0001-Don-t-pass-CFLAGS-to-the-C-compiler.patch
f9773277e91e91d0bd6749890b8d332a86522927d90548af02892c6d01b8fbb3b234993eec8e5b8d6a3b6f1cec310a112e274f47f70d30829ca61a0da8d45bb5 0002-Fix-LLVM-build.patch
9e87964d41e14f70acc1961a0162bbf3ebca73f1c2b2842c3b1c8b65776466c9299d6974fc6b94a4e06547ae8ce638c28cdedf24eeb2616976f9dd727b989c13 0003-Allow-rustdoc-to-work-when-cross-compiling-on-musl.patch