summaryrefslogtreecommitdiff
path: root/user/s6-linux-utils
diff options
context:
space:
mode:
authorLaurent Bercot <ska-adelie@skarnet.org>2019-10-03 10:24:19 -0500
committerLaurent Bercot <ska-adelie@skarnet.org>2019-10-03 10:24:19 -0500
commit651e22f2032fd7949e52102aa000c5943e654e42 (patch)
treedca7092376fa151e34fbacf7cb96220c9bab01dc /user/s6-linux-utils
parent6989744a9f1085ff4ecd7d4317331e4c31c3b937 (diff)
downloadpackages-651e22f2032fd7949e52102aa000c5943e654e42.tar.gz
packages-651e22f2032fd7949e52102aa000c5943e654e42.tar.bz2
packages-651e22f2032fd7949e52102aa000c5943e654e42.tar.xz
packages-651e22f2032fd7949e52102aa000c5943e654e42.zip
user/s6-linux-utils: new package
Diffstat (limited to 'user/s6-linux-utils')
-rw-r--r--user/s6-linux-utils/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/user/s6-linux-utils/APKBUILD b/user/s6-linux-utils/APKBUILD
new file mode 100644
index 000000000..73c96b67c
--- /dev/null
+++ b/user/s6-linux-utils/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Laurent Bercot <ska-adelie@skarnet.org>
+# Maintainer: Laurent Bercot <ska-adelie@skarnet.org>
+pkgname=s6-linux-utils
+pkgver=2.5.1.0
+pkgrel=0
+pkgdesc="skarnet.org's Linux-specific miscellaneous utilities"
+url="https://skarnet.org/software/s6-linux-utils/"
+arch="all"
+options="!check"
+license="ISC"
+_skalibs_version=2.9.0.0
+depends=
+makedepends="skalibs-dev>=$_skalibs_version skalibs-libs-dev>=$_skalibs_version"
+subpackages="$pkgname-doc"
+source="https://skarnet.org/software/$pkgname/$pkgname-$pkgver.tar.gz"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --disable-allstatic \
+ --prefix=/usr \
+ --with-dynlib=/lib
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+
+doc() {
+ pkgdesc="$pkgdesc (documentation)"
+ depends=
+ install_if="docs $pkgname=$pkgver-r$pkgrel"
+ mkdir -p "$subpkgdir/usr/share/doc"
+ cp -a "$builddir/doc" "$subpkgdir/usr/share/doc/$pkgname"
+}
+
+sha512sums="03c63e3772812da99ffaa4c83163626bcdfe4887bb1a9bd576e21b0ff3c2c2a7de49234f9e2fd4d0881758b20ac2ef0cb827a20b32004cd7bf6e05c921f32d0e s6-linux-utils-2.5.1.0.tar.gz"